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1 Introduction

This tutorial teaches the INCA novice all elementary steps applicable to two typ-
ical tasks performed with INCA: measurement and calibration. The tutorial does
not require any knowledge of INCA.

1.1 Intended Use
INCA and INCA add-ons are developed and approved for automotive applications
and procedures as described in the user documentation for INCA and INCA add-
ons.

INCA and the INCA add-ons are intended to be used in industrial labs and in test
vehicles.

ETAS GmbH cannot be made liable for damage that is caused by incorrect use
and not adhering to the safety information.

1.2 Target Group
This software product and this user guide address qualified personnel working in
the fields of automotive ECU development and calibration, as well as system
administrators and users with administrator privileges who install, maintain, or
uninstall software. Specialized knowledge in the areas of measurement and ECU
technology is required.

1.3 Classification of Safety Messages
Safety messages warn of dangers that can lead to personal injury or damage to
property:

DANGER

DANGER indicates a hazardous situation that, if not avoided, will result in death
or serious injury.

WARNING

WARNING indicates a hazardous situation that, if not avoided, could result in
death or serious injury.
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CAUTION

CAUTION indicates a hazardous situation that, if not avoided, could result in
minor or moderate injury.

NOTICE
NOTICE indicates a situation that, if not avoided, could result in damage to
property.

1.4 Safety Information
Observe the following safety information when working with INCA and INCA add-
ons:

WARNING

Risk of unexpected vehicle behavior

Calibration activities influence the behavior of the ECU and the systems that
are connected to the ECU.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Only perform calibration activities if you are trained in using the product and
can assess the possible reactions of the connected systems.

WARNING

Risk of unexpected vehicle behavior

Sending messages via bus systems, such as CAN, LIN, FlexRay, or Ethernet,
influences the behavior of the systems connected to it.

This can lead to unexpected vehicle behavior, such as engine shutdown as well
as breaking, accelerating, or swerving of the vehicle.

Only perform the sending of messages via a bus system if you have sufficient
knowledge in using the respective bus system and can assess the possible
reactions of the connected systems.

Adhere to the instructions in the ETAS Safety Advice and the safety information
given in the online help and user guides. Open the ETAS Safety Advice in the INCA
help menu ? > Safety Advice.
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1.5 Data Protection
If the product contains functions that process personal data, legal requirements
of data protection and data privacy laws shall be complied with by the customer.
As the data controller, the customer usually designs subsequent processing.
Therefore, he must check, if the protective measures are sufficient.

1.6 Data and Information Security
To securely handle data in the context of this product, see the INCA Help section
“Data and Information Security”.
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2 INCA Basics

INCA is a measuring, calibration, and diagnostic system that provides com-
prehensive measuring support. INCA aids you in all essential tasks during control
unit calibration, evaluates the measured data, and documents the calibration res-
ults.

INCA lets you read measured data from the control unit and the engine in parallel.
The program helps you determine measured engine data such as lambda, dif-
ferent temperatures and voltage values, etc. With INCA, you don't just get a tool
that will adapt to a variety of different control units, but also a system that will
optimize a wide range of different vehicle components.

INCA is an "open system". Consistent implementation of the ASAM-MCD stand-
ard and support for data exchange formats that are established in this envir-
onment allow this program to be used for any ECU interfaces (can be customized
to any manufacturer's control units) and to be integrated in existing data pro-
cessing infrastructures.

INCA consists of a measurement and calibration core system which can be
enhanced by various add-ons and customized extensions (e.g. INCA-MIP,
INCA-QM-BASIC, INCA-FLEXRAY) that can be integrated in INCA. In addition to
that, INCA offers open interfaces which allow for the adaptation of INCA core cap-
abilities as well as the remote control of INCA by other applications.

Fig. 2-1: INCA System Overview
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2.1 Concepts
This section introduces the main concepts and procedures used in the tutorial:

Measurement task

The state of the engine is assessed using sensors. A sensor measures an
engine parameter and makes the value available to the ECU as a number. The
measurement task consists of sampling all sensor values over a certain period
of time, and recording them. The resulting record documents the engine beha-
vior for a certain set of calibration values.

Calibration task

It is the task of the ECU (Electronic Control Unit) to control the engine so it
exhibits a desired behavior. The ECU uses a feedback process to do this: it
measures the state of the engine using sensors, and then changes the state
of the engine towards the desired behavior using actuators. The new state is
measured and adjusted again and again, until an equilibrium is reached. Cal-
ibration is the process of adjusting the feedback parameters in such a way
that the car exhibits the desired behavior when the equilibrium state is
reached. Because the state of the car changes as it is driven, there are many
of these equilibrium states, usually called process points. A car is non-linear
system, and the control algorithm cannot rely on mathematics to determine
the feedback values. Instead it looks up the required actuator settings in a set
of tables, using the sensor values as lookup criterion. The calibration task con-
sists of setting the values in the tables. The same ECU can have different valid
sets of calibration values implementing a different behavior, one set for a fast
car, for example, and another set for an economical car.

Memory Emulation

Classically, the ECU memory consists of read-only memory for calibration
data. This means that the calibration data can't be changed directly. You use
hardware, such as the ES800 system in combination with INCA, to bridge the
ECU's read-only memory with random access memory. The calibration data
are then loaded into the INCA random access memory, enabling calibrators to
change the data on the fly without having to change the contents of the
actual ECU memory.

Some modern ECUs use the CAN bus protocol, which provides calibration sup-
port. If CAN calibration support is implemented in the ECU program, it is pos-
sible to change the ECU data on the fly without having to emulate the ECU
memory. To make CAN possible the ECU contains a programmable semi-per-
manent memory, the contents of which remains available after a power cycle.
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Variables, measure variables, calibration variables (characteristics, curves,
and maps)

The term variable is used as a collective name for both measure variables and
all types of calibration variables.

In general, a measure variable is a value passed by a sensor, and can be used
as a lookup value for calibration variables. Moreover, it is possible to measure
derived or calculated characteristics, or, with corresponding settings, also cal-
ibration variables.

There are three types of calibration variables:

1. Characteristics are fixed values used as constants by the ECU program
after they are adjusted during the calibration process.

2. The ECU uses look-up table to determine the required value of an actuator
setting as a function of measure variables (see Calibration Task). If one
variable is used to look up one output value, the table is called a curve,
because it can be represented graphically as an xy-curve.

3. A look-up table using two or more measure variables to find one output
value is called a map, because of the analogy to an elevation map; think of
the input variables as the coordinates, and the output value as the elev-
ation of a certain location on the map.
Maps that derive the output value from three or more input values are
called multi-dimensional maps.

Process point

For any curve or map, the process point is the current lookup value passed to
the ECU. The process point changes with the value of the measure variable
used as lookup criterion into the curve or map. The process point can be visu-
alized on the map; in a tabular calibration editor the cell holding the current
lookup value is 'selected'. As the process point changes, the selection moves
across the cells of the table.

Database and Database Manager

All data created while performing calibration and measurement tasks (work-
spaces, experiments, projects, datasets, measurement variables catalogues,
and CAN-DB descriptions) are kept in a database. In order to effectively use
and organize the data INCA features the Database Manager, allowing you to
access, reorganize and create data through a graphical user interface. The
Database Manager is the INCA main window, which is the window you see
after starting up INCA.

INCA can handle more than one database at a time. This allows you to seg-
ment your data into several sets, each corresponding to a single experiment
or vehicle, and store them in their own database. This makes the data more
transparent and enhances INCA's performance.
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Workspace

A workspace is the umbrella combining the experiment, the project, and the
hardware configuration into a consistent file set you can save and load
between calibration sessions.

Experiment

An experiment is a predefined set of windows filled with those variables and
maps needed to perform a certain calibration or measurement task. An exper-
iment is stored in the database and allows you to quickly set up INCA for a cer-
tain task by loading it.

Project

A project consists of the definition of all values related to calibration, and a
dataset reflecting a certain version of the ECU program and calibration values.
The project is stored in two files: a *.a2l and a *.hex file, and referenced in
the database.

The A2L description file (*.a2l) contains the physical description of the data
and/or parameters of the control unit program, e.g.:

Structural information

Memory size

Address ranges (e.g. of each measured signal and parameter)

Names of the measured signals and parameters

The hex file (*.hex, *.s19; Intel hex or Motorola format) contains the control
unit program consisting of the code and the data. The contents of this file can
be directly loaded into the control unit and executed by the respective pro-
cessor.

Hardware Configuration

The hardware configuration defines the hardware used for a certain task and,
for application hardware, the project to be used and the corresponding data-
set.

Dataset

The values making up the characteristics, curves and maps are stored in per-
manent memory in the ECU, and accessed by the ECU processor. A set of cal-
ibration values stored in the database is called a dataset. Datasets are
versioned; a certain version corresponds to a certain calibrated behavior. Data-
sets are stored in *.hex or *.s19 files and referenced in the database.

INCA provides the Memory Page Manager to manage different datasets (work-
ing and reference datasets). This is a versatile tool which you can use to copy
memory contents in any direction. For example, it allows you to read data ver-
sions into and from the control unit or copy data from the working data version
to the reference data version or vice versa.
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The different datasets of the working page and reference page are stored sep-
arately in INCA as the working dataset and the read-only reference dataset.
Read-only datasets are identified by a red frame.

When loading the first HEX file, the code portion is mapped to the control unit
project (transparent to the user). The data portion of this HEX file is stored as
the so-called "Master" dataset. The master dataset is then used to also cre-
ate the required working dataset.

User profile

A user profile is a collection of settings for a certain user determining the look
and feel of the INCA user interface. A profile can be saved and loaded
between sessions. This allows users to quickly configure the INCA user inter-
face settings to fit their requirements. Profile settings include start behavior,
window size, window arrangement, paths and many more.

Measure Data Analyzer

The Measure Data Analysis (MDA) program is an offline instrument for dis-
playing and analyzing recorded measurement data. It runs in its own program
window and works in display mode or in analysis mode. Its appearance and
functions resemble those of an oscilloscope in the INCA Experiment Envir-
onment. Online measurement, however, is not possible in MDA.

2.2 Concepts Applied to the Calibration Process
Fig. 2-2 shows the calibration cycle, and the role of INCA in the measurement and
calibration processes. The engine's behavior is dictated by calibration data
present in the ECU. During a calibration session the calibrator works on the cal-
ibration data to optimize the engine's behavior.

1. By emulating parts of the ECU's memory INCA allows dynamic changes to
the calibration data.

2. By providing a window on the on-line data in the ECU INCA allows cal-
ibrators to inspect the engine's behavior and see if their changes have the
desired effect.

3. The recording capabilities integrated into INCA allow the tester to present
the test data in a report.
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Fig. 2-2: The Calibration and Measurement Applications
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Fig. 2-3 shows a functional block diagram of INCA. INCA interfaces with the ECU
and can directly access its memory. A graphical user interface allows the user to
interact with the ECU.

1. INCA can emulate the ECU memory.

2. The ECU then uses the data in INCA as if they were its own.

3. This allows the calibrator to manipulate the calibration data and ECU pro-
gram on the fly without having to change the actual ECU memory.

4. INCA can access the ECU memory directly. Measurements can be recorded
to be used in reports.

Fig. 2-3: Memory emulation
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3 Preparation

Before starting with the tutorial you must prepare the system.

You must have an INCA system installed and running on the computer you want
to use for the tutorial. INCA can be started from an icon on the desktop, or from
the Startmenu.

Note

The tasks in the tutorial can be performed in demo mode, meaning you do not
need any actual hardware. The hardware is simulated by the ETK Test Device
and the VADI Test Device. The devices are installed along with the INCA soft-
ware; you do not have to install them separately.

Make sure that the following files are present in the
<INCA base>

1)
\ETASData\INCA7.5\Data\Demo directory:

0400.hex

0400.a2l

Make sure that the computer you use for this tutorial has an Internet browser
installed on it, and that the extension .HTM is associated with the browser.

Overview and objectives
Lambda calibration optimizes the way that fuel is burned in the engine in order to
reduce overall fuel consumption and emissions. The Lambda value specifies the
air-fuel-ratio of the air-fuel mixture that gets burned inside the cylinder. Accord-
ing to theory you need 14.7 kilograms of ambient air to completely burn 1 kilogram
of fuel. Before the introduction of Engine Control Units (ECUs), the only way to
make sure the engine would run in any environment (during a cold start, for
example) was to adjust the amount of air let into the engine below the the-
oretical amount, making the mixture richer in fuel. The result of this was that not
all the fuel in the mixture was burned, and the exhaust gas would be rich in
unburned and half-burned fuel. This method of running the engine with too little
air is called rich engine management.

ECUs enabled using the measured value fuel rest in the exhaust gas (Lambda) in
a control loop making the engine use less fuel. The new method is called lean
engine management. In this tutorial you analyze and calibrate the control loop
enabling lean engine management: the value of the Lambda sensor in the
exhaust pipe is used to control the air throttle at the engine inlet.

1) Disk drive or root directory containing the corresponding folder
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What you have learned after completing the tutorial
At the end of the tutorial you will be able to perform measurement and calibration
tasks well enough to be able to work out the finer details of INCA's functionality
with the aid of the on-line help system as a reference as you practice your skills
during your first real assignments with INCA. In addition, you will have a profile
and a sample workspace and experiment at your disposal that you can use to
jump-start your future calibration assignments.
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4 Lesson: Creating the Database

Learning time: 15 minutes.

4.1 Objectives
You will ready the INCA system for the Lambda calibration task by setting up the
database you need to carry out the task.

4.2 Review of the Most Important Concepts

Database and Database Manager

All data created while performing calibration and measurement tasks (work-
spaces, experiments, projects, datasets, measurement variables catalogs, and
CAN-DB descriptions) are kept in a database. In order to effectively use and
organize the data INCA features the Database Manager, allowing you to access,
reorganize and create data through a graphical user interface. The Database
Manager is the INCA main window, which is the window you see after starting up
INCA.

INCA can handle more than one database at a time. This allows you to segment
your data into several sets, each corresponding to a single experiment or vehicle,
and store them in their own database. This makes the data more transparent and
enhances INCA's performance.

4.3 Tasks
After starting INCA you see the user interface (see image in the next chapter
Create a New Database), the Database Manager. The top left field, Database
Objects, that shows the database tree structure is referred to as the navigator
field in this tutorial. The navigator field shows all elements in the current data-
base. The structure you see reflects the database structure, not the hierarchical
structure outlined in the concepts chapter. You can expand and collapse folders
in the database by clicking the + and - icons, and select objects in the folders by
clicking them, like in Windows Explorer.

The other fields provide information about the object currently selected in the
navigator field.

The bottom left field is used for general comments about the item which is selec-
ted in the field above.

The right side of the Database Manager is variable. Which fields are displayed
here, as well as the information in them, also depends on the type of object selec-
ted in the navigator field.
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4.3.1 Create a New Database
It is recommended that you create a new database for every new experiment.
This practice keeps the data transparent and the data volume associated with
individual experiments manageable.

To create a new database

1. Select Database > New.

2. In the "New Database" dialog, enter Tutorial.

3. ClickOK.

After this, the navigator field is empty except for the item DEFAULT, which is a
default and empty folder. The second field in the status bar along the bottom of
the screen indicates which database is active: DB:<Tutorial>.

4.3.2 Create a Top Folder in the Database
To be able to create database items such as workspaces, experiments, and pro-
jects, you must first create a top folder. In the next few lessons you create
folders with the other database elements as sub-folders under the top folder.
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To create a top folder

1. Select Edit >Add>Add top folder.

2. Rename the new folder Tutorial and press <ENTER>.

The top folder is displayed in the navigator field as shown in the screen shot
above. Below the top folder you create the other folders in the other lessons of
the tutorial.

4.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. The right side of the Database Manager always contains the same fields.
A. True

B. False

2. Arrange the following steps in the correct order:
A. Create database structure

B. Create database

C. Create top folder

4.5 Summary
In this lesson you learned how to create a new database with its top folder.
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5 Lesson: Setting Up a Workspace

Learning time: 30 minutes

5.1 Objectives
In this lesson you set up a workspace for Lambda calibration. The workspace con-
tains an experiment as well as a project with its hardware configuration. In addi-
tion, you learn to configure the hardware module by adding an auxiliary
measurement device.

5.2 Review of the Most Important Concepts

Workspace

A workspace is the umbrella combining the experiment and the project into a
consistent file set you can save and load between calibration sessions.

Project

A project consists of the definition of all values related to calibration, and a
dataset reflecting a certain version of the ECU program and calibration values.
The project is stored in two files: a *.a2l and a *.hex file, and referenced in
the database.

The a2l description file (*.a2l) contains the physical description of the data
and/or parameters of the control unit program, e.g.:

Structural information

Memory size

Address ranges (e.g. of each measured signal and parameter)

Names of the measured signals and parameters

The hex file (*.hex, *.s19; Intel hex or Motorola format) contains the control
unit program consisting of the code and the data. The contents of this file can
be directly loaded into the control unit and executed by the respective pro-
cessor.

Hardware Configuration

The hardware configuration defines the hardware used for a certain task and,
for application hardware, the project to be used and the corresponding data-
set.

Dataset

The values making up the characteristics, curves and maps are stored in per-
manent memory in the ECU, and accessed by the ECU processor. A set of cal-
ibration values stored in the database is called a dataset. Datasets are
versioned; a certain version corresponds to a certain calibrated behavior. Data-

INCA V7.6 | Tutorial



5 Lesson: Setting Up a Workspace | 23

sets are stored in *.hex or *.s19 files and referenced in the database. These
files are binary images of the ECU memory, and beside the calibration data
they also contain the ECU program itself.

INCA provides the Memory Page Manager to manage different datasets (work-
ing and reference datasets). This is a versatile tool which you can use to copy
memory contents in any direction. For example, it allows you to read data ver-
sions into and from the control unit or copy data from the working data version
to the reference data version or vice versa.

The different datasets of the working page and reference page are stored sep-
arately in INCA as the working dataset and the read-only reference dataset.
Read-only datasets are identified by a red frame.

When loading the first HEX file, the code portion is mapped to the control unit
project (transparent to the user). The data portion of this HEX file is stored as
the so-called "Master" dataset. The master dataset is then used to also cre-
ate the required working dataset.

5.3 Tasks

5.3.1 Create a Workspace
First you must create a new workspace in the database.

To create a workspace

1. Select the top folder you want to create the workspace in. Here, select the
Tutorial folder.

2. Select Edit > Add > Add Folder.

3. Rename the new folder to Workspace and press <ENTER>.

4. Make sure the Workspace folder is selected.
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5. Select Edit > Add > Workspace.

6. Rename the new workspace OneETK and press <ENTER>.

The name OneETK is chosen to reflect the environment used in this tutorial: a
setup with a single ETK. An ETK is a parallel interface to the ECU used by INCA.

If the new workspace is selected you see some empty fields on the right side of
the Database Manager that contains the experiments, projects, and hardware
for the workspace. To be able to fill these fields with the appropriate experiment,
project, and hardware, you must first create them.

In order to be able to use a database object in your workspace, you must assign it
explicitly to the workspace.

In this lesson you create the project and the hardware description. In the next les-
son you create the experiment.

5.3.2 Create and Assign a Project
After assigning the A2L file to the project, INCA is able to access and interpret
the memory contents of the described ECU. Note that this also means that while
working with this description, INCA can access only the exact ECU described by
the description file, and no other.

The project is placed in a new project folder, which is placed directly under the
top folder, not as a subfolder to the workspace folder. This enables you to use
the project hardware for different experiments, which use different workspaces.
Although such a database folder structure is not one-to-one with the INCA use
model, it allows full leverage of all the database elements you create. This
approach works well for beginners, but keep in mind that there are many ways to
organize your data. In the future you may want to develop other schemes to fit
the requirements of a certain project.

INCA V7.6 | Tutorial



5 Lesson: Setting Up a Workspace | 25

The ECU cannot work without values for the characteristics, curves and maps, so
in addition to the description of the ECU memory, INCA needs an initial set of cal-
ibration data to work with. Note that the calibration data are not part of the
description file, and you can have many calibration datasets in a single project,
each representing a different phase in the calibration, or a different calibration
profile.

To create and assign a project

1. Select the top folder Tutorial.

2. Select Edit > Add > Add Folder.

3. Rename the new folder Project_0400.

4. Make sure the Project_0400 folder is selected.

5. Select Edit > Add > ECU project (A2L).

The "Read ASAM-2MC from:" dialog pops up.

6. Browse to the <INCA base>\ ETASData\INCA7.5\Data\Demo dir-
ectory, select the file 0400.a2l and clickOpen. 

The "Select Data File" dialog appears.

7. Browse to <INCA base>\ETASData\INCA7.5\Data\Demo directory, select
the file 0400.hex, and clickOpen.
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Note that only the description, not the calibration dataset, is shown as a
separate database item in the database navigator field. If you select the
new project description 0400 in the navigator field you see all calibration
datasets valid for this description in the Datasets field on the right-hand
side of the Database Manager. Continue with assigning the newly created
project to the OneETK workspace:

8. Select OneETK workspace in the Workspace folder.

9. Select Project > Add Project/Dataset.

The "Select project and working data" dialog appears.

10. Select the 0400 project in the navigator field on the left-hand side of the
dialog.

11. Select the master dataset 0400 in the Datasets field on the right-hand
side of the dialog.

12. ClickOK.
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The "Add new device for project" dialog opens.

If you do not explicitly assign a device and close this dialog withCancel, an
offline device is assigned by default after selecting a project/dataset. This
hardware is intended as a placeholder if you do not select a device right
now and want to prepare your experiment at first.

In the present example, a ES592 is to be used instead of the offline device.

13. Under ES592, select device ETKC.

14. ClickOK.

Now select the OneETK workspace in the navigator field, and have a look at
the fields on the right-hand side of the Database Manager.
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You see:

The Experiment field at the top contains the experiment assigned to the
workspace. Because you have not assigned an experiment yet, this field is
empty. You assign an experiment in "Lesson: Setting Up an Experiment" on
page 36.

Two boxes in the Project/Device field.
The left box has three entries indicating the currently used project data.

The top entry (0400) is the name of the project description.

The next entry (WP: 0400_1) is the name of the currently used working
dataset (WP means working page and refers to a 'page' of memory with the
working dataset). Note that you have neither created a working dataset,
nor assigned the name 0400_1. Because a project must have a working
dataset, 0400_1 was created and named automatically by INCA using the
master dataset you loaded earlier as a basis (the use of working and ref-
erence datasets is explained in "Lesson: Calibration" on page 69).

The last entry (RP: 0400) is the currently used reference dataset (RP
means Reference Page), referring to a read-only copy of the master data-
set.

The right frame contains the ES592:1and the ETKC:1 entry that is the
hardware module currently used. Since a project in INCA must always have
a hardware module, we have selected this hardware module temporarily.

5.3.3 Configure the Project Hardware
To be able to perform the tutorial without real hardware, the hardware must be
simulated. For this reason, the ES592 is replaced with a test system in this step.
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Note

The TS test system simulates a real hardware. The test system can be used to
measure simulated measured values and change calibration variables without
using real hardware. However, the test system does not perform any raster
check and is, therefore, not suitable for preparing a real experiment. It is used
solely for exercise purposes.

In this tutorial you add the ETK Test Device hardware to the OneETK work-
space.

To configure the project hardware

1. Select the ETKC:1 hardware module in the right frame of the Pro-
ject/Device field in the Database Manager.

2. Select Device > Replace Device.

3. INCA analyzes the project and displays the Add new device for project
dialog, with a list of hardware interfaces and associated devices.

The list is based on specifications given in the project description file.

4. Select the ETK test device listed under the TS test system inter-
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face, and clickOK.

Now, if you select the OneETK workspace again, you see that the current hard-
ware module has changed to ETK test device:1, and that the same device is
listed for the TS test system:1 interface in the Hardware field. The ES592
device has been replaced by the new device, and has disappeared.

The hardware module you have defined can access the ECU using the definitions
given in the project description file. Often, however, you want to use additional
measurements from hardware components external to the ECU. Because these
modules aren't specified in the project description file, you must provide the
description of the values returned by the modules yourself. This task is called
'configuring the device'. As an example, you now add the VADI test device..

Note

If real INCA hardware is connected to the computer, you can also have INCA
automatically search for available devices by using the menu option Hardware
> Search for hardware. In this tutorial, however, the devices are simulated,
and are added manually.

To add the additional VADI hardware component

1. Select the OneETK workspace.

2. Select Device > Configure Hardware or click .

The Hardware Configuration Editor appears.
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By displaying Hardware: >OneETK< in its title bar the window indicates
that the device to be configured is added to the hardware module of the
OneETK workspace. The Hardware Devices field at the left-hand side of the
window shows the dependencies of the devices in a tree structure. Do not
confuse this tree structure with the navigator field of the Database Man-
ager; the Hardware Configuration Editor shows hardware components
only. The right-hand side of the Hardware Configuration Editor shows the
configuration parameters for the device to be configured. The information
is distributed over several forms accessible through the tabs along the top
of the forms. Proceed by adding the new VADI device:

3. Select the TS Test System:1 interface in the Hardware Devices field of
the Hardware Configuration Editor.

4. Select Device > Insert.

5. The Add Hardware device dialog appears, showing a list of available
devices.

6. Select VADI test device from the list, and clickOK.
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7. You return to the Hardware Configuration Editor. The entry VADI test

device:1 (1) is added to the devices listed in the Hardware devices
field.

If you now select the VADI test device:1 (1), the right-hand side of the
Hardware Configuration Editor shows the parameters for the new device. The
form with the Parameters tab allows you to set parameters for the entire module.
The form with the Info tab gives information about the device. The form with the
Channels tab allows you to configure the individual channels of the VADI device.

For this tutorial, keep the default values, created automatically when you added
the device, for all the parameters of the VADI device.

Note the stop icons displayed in front of the devices listed in the Hardware
devices field of the Hardware Configuration Editor. The stop sign means that
the device is specified, but not yet active. To activate the devices, you must ini-
tialize them. When you initialize devices, INCA attempts to establish a connection
to all the devices specified in the hardware module. For those devices where the
initialization was successful, the icon changes to a sign with an up arrow to indic-
ate the device is active.

Note

In this tutorial, you can initialize the devices even though no actual hardware is
connected to the computer because the devices are simulated. In a real work-
space, in which you are using real and non-simulated hardware, you can suc-
cessfully initialize and enable these devices only if they are connected and
have a current firmware status. The firmware status is displayed in the Hard-
ware status dialog window or in the bottom toolbar of the experiment.
Additional information about the hardware status is available in the online help
of the Hardware Configuration Editor under "Hardware Status Display".
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To show the hardware status and initialize the hardware devices

1. Select Hardware > Hardware Status.

INCA initializes the hardware and shows the results, as well as other status
information, in the Hardware Status dialog.

Note

If the hardware is not automatically initialized, automatic initialization
might be switched off. This is useful in cases such as preparing work-
space and/or experiment offline, when you don't need to access the
hardware. To enable automatic hardware initialization, go to the Data-
base Manager and select Experiment > Experiment without full HW
access.

The contents of the Hardware Status dialog are continuously refreshed.
This makes it a useful monitoring tool in environments where the con-
nection to the hardware devices are subject to change. Under such con-
ditions you can evoke the Hardware Status dialog and leave it open as
long as appropriate.

2. Close the Hardware Status dialog and return to the Hardwarewindow.
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The hardware devices are automatically initialized. In the Hardware
Devices field, the icons change from red to green.

3. Close the Hardwarewindow to go back to the Database Manager.
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5.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. A workspace contains only a hardware description for the current exper-
iment.

A. True

B. False

2. Which of the following items are part of the project description file:
A. Memory layout of the ECU.

B. Most recent calibration dataset.

C. Master dataset.

D. Format of the characteristic, curves and maps.

E. Format of the variables returning sensor values.

3. Match the tasks below with the appropriate user interface element used to
perform them:

Tasks:

A. Add a new device.

B. Set the acquisition rate of an auxiliary measurement
device.

C. Initialize hardware.

D. Create a project folder.

E. Load a project description file.

User Interface elements:

A. Database Manager

B. Hardware Configuration Editor

5.5 Summary
In this lesson you created the 0400 project, loaded its project description, as well
as a master dataset. You configured the hardware used to access the project
ECU, as well as the auxiliary VADI device.

INCA V7.6 | Tutorial



6 Lesson: Setting Up an Experiment | 36

6 Lesson: Setting Up an Experiment

Learning time: 30 minutes

6.1 Objectives
In this lesson you learn how to add variables and windows to an experiment and
how to configure them.

6.2 Review of the Most Important Concepts

Experiment

An experiment is a predefined set of windows filled with those variables and
maps needed to perform a certain calibration or measurement task. An exper-
iment is stored in the database and allows you to quickly set up INCA for a cer-
tain task by loading it.

Variable

The term variable is used as a collective name for both measure variables and
all types of calibration variables.

Measurement Variables

In general, a measure variable is a value passed by a sensor, and can be used
as a lookup value for calibration variables.

Moreover, it is possible to measure derived or calculated characteristics, or,
with corresponding settings, also calibration variables.

6.3 Tasks

6.3.1 Create and Assign an Experiment
It is possible to use the same experiment in different workspaces within the data-
base, independent of its location. It is recommended to create a separate folder
for experiments in order to keep the database clearly structured. Therefore in
this tutorial, the experiment is placed in a new experiment folder directly under
the top folder, not as a subfolder to the workspace folder.

Note

INCA 7.1 uses a new oscilloscope for experiments. The experiment created in
this tutorial already uses this oscilloscope automatically. Experiments created
in older INCA versions can be converted so that the new oscilloscope can also
(exclusively) be used in these. This tutorial indicates when this is possible
using appropriate notes.
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To create and assign an experiment

1. Select the top folder, Tutorial.

2. Select Edit > Add > Add Folder.

3. Rename the new folder Experiment.

4. Make sure the Experiment folder is selected.

5. Select Edit > Add > Experiment.

6. Rename the new experiment LambdaControl.

7. Select the OneETK workspace in the navigator field.

8. Select Experiment >Change Experiment.

9. The Select Experiment dialog appears. In the Database Objects field,
expand the Experiment folder.

10. In the Database Objects field, select the LambdaControl experiment and
confirm withOK.

If you now select the OneETK workspace in the navigator field of the Data-
base Manager, you see that the LambdaControl experiment appears in
the Experiment field at the top right of the Database Manager.

Note

The experiment you have created is automatically assigned the symbol
for experiments using the new oscilloscope ( ).
Experiments that support the old oscilloscope are assigned a modified
symbol ( ) so that they can be differentiated.

6.3.2 Run the Experiment
Experiments run in the Experiment Environment. The Experiment Environment
is a self-contained user interface like the Database Manager, but is specialized
for doing experiments. If you launch the Experiment environment in a specific
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working environment, the window for the experiment for that working envir-
onment is the default. In this way, you can start measurement or calibration activ-
ities without having to set up an experiment.

Note

If you are running an experiment from an older INCA version for the first time, a
dialog box will appear for automatically converting the experiment for the new
oscilloscope. Confirm this dialog box with Yes if you would like to exclusively
edit this experiment in INCA 7.1 in the future. Additional information on using
experiments in different INCA versions can be found in our online help.

To run the Experiment

1. Select the OneETK workspace in the navigator field of the Database Man-
ager.

2. Select Experiment > Run experiment.

The Experimentwindow opens.

The window is configured according to the presets for the experiment
assigned to the workspace that was selected when you ran the exper-
iment. The title bar of the window, Experiment: "Lambda Control" Hard-
ware: "OneETK", indicates this. Because the experiment is new and has not
been set up yet, the window is empty. In the remainder of this lesson you
set up the Lambda Control experiment for the measurement task you per-
form in the next lesson.

6.3.3 Select the Variables Used in the Experiment
The variables return values measured by the sensors connected to the project
ECU. Only a subset of the values measured by the ECU is needed for the
LambdaControl experiment. After selecting the variables of interest, they are
displayed in child windows to the Experimentwindow in a format of your choice.

In this lesson you limit yourself to selecting the variables needed for the meas-
urement task you perform in the next lesson. Calibration variables (char-
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acteristics, curves, and maps) are selected the same way as measurement vari-
ables. You will add calibration variables in the "Lesson: Calibration" on page 69
exercise dealing with calibration activities.

To select the variables for the Lambda control experiment

1. In the experiment environment, select Variables > Variable Selection.

The Variable Selection dialog opens.

The Sources field at the left-hand side of the window lists all hardware devices in
the hardware configuration of the current workspace. When you select a certain
device, the variables list on the right hand side lists all characteristics, curves,
and maps accessed through the device.

Note

Only the icons of variables actually used are described in the tutorial. The com-
plete description of the icons is located in the online help.

Each entry in the variables list is preceded by three icons providing some inform-
ation on the variable.

The first icon shows whether it is a measure or calibration variable:

Measurement

Calibration

The second icon indicates the type of the variable, i.e. whether it is for instance a
scalar, a curve or a map.

Scalar

Boolean (logical)

Vector

Matrix

Curve
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Map

Axis

ASCII

Curve axis

Multi-dimensional map

The third icon indicates your access rights for the variable.

Readable and writable

Readable only

In this lesson you use only measure variables, which have a red square as their
first icon.

1. Expand the ETK Test Device:1 entry in the "Sources" field of the "Vari-
able Selection" dialog.

2. Expand the tree structure of the Functions entry.

A list of functions appears.

3. Select LambdaRegelung from the list.

The entries in the Variables field are now limited to those measure and cal-
ibration variables associated with the Lambda control function.

4. Scroll through the list and select the variable B_FRMAX.

The following symbol assigned to the variables indicates that they will be
added to the experiment.

5. ClickOK to have it displayed in the default window.

The selected variable is now added to the Experiment window. It is dis-
played as a line inMeasure window [1].

You may have noticed that the list of variables contains many entries that are not
of interest to the measurement you are setting up. This makes the process of
searching for the appropriate variables tedious. In this lesson you are only inter-
ested in measure variables and INCA provides a built-in filter allowing you to limit
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the list of variables to show only measure variables. In the lesson covering the cal-
ibration task you use another filter, limiting the list to only calibration elements
such as characteristics and maps. Before selecting the rest of the measurement
variables, turn on the filter for measured values:

To use filters for variable selection

1. Select Variables > Variable Selection.

The Variable Selection dialog opens. Note that B_FRMAX is marked with a
blue rectangle . This indicates that the variable is already being used in the
experiment.

2. Click .

The list of variables is limited to measures variables only. Scroll down the
list, and select the following variable:
B_FRMIN

You can speed up the search for a certain variable by typing the first letters
of its name.

3. Type the letters dt.

The letters are displayed in the toolbar in the edit box of the alphabetical fil-
ter. The datalist is automatically filtered according to the entry so that only
variables starting with DT are displayed (the search is not case-sensitive).

4. Select the variable DTVKA.

5. Using the same method, select the following variables:
FRPS

RTV

6. Remove your entries from the alphabetical filter.

7. In the toolbar, click on the following icon to check which variables are
added.

8. Select all variables in the list.

9. Right-click on the lists of variables and select Add to > Layer_1 > Meas-
ure window [1] from the context menu.

10. Click onOK.

All variables are added as lines toMeasure window [1].

Note

When you use the alphabetical filter to search for variables, you can also use
wildcards (e.g. *,?). With these wildcards, you can search for variables where
you only know parts of their names.
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Rasters are used to determine the intervals in which measure values are meas-
ured. Which rasters are available is defined in the ECU's projection description
file. You can record only a certain number of measure variables in one raster. The
raster filling display indicates whether further variables can be measured in the
desired raster.

To assign a raster upon variable selection

1. Select Variables > Variable Selection.

The Variable Selection dialog opens.

2. In the Sources field, click on the entry ETK Test Device:1.

3. Select the following variables from the variables list using the filters:
LR_P_Anteil

LR_I_Anteil

FR

FLR_AP

4. Remove your entries from the alphabetical filter.

5. In the toolbar, click on the following icon to check which variables are
added.

You can see in the variables list that Raster_A is being selected for all of
the four variables. In the information at the bottom on the right you can see
that the raster filling level for Raster_A is 3%.

You change the raster of a variable by moving the check mark in the raster
matrix in the column of the corresponding raster.

6. For the variables FR and FLR_AP, select Raster_B.

7. For the variables LR_P_Anteil and LR_I_Anteil, select Raster_C.

8. ClickOK.

The variables that you have selected in this session are displayed in a new
Measure window [2].
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Note

If you do not assign the variable to a window upon selecting it, it is displayed in
a standard window. In "Lesson: Settings and user profiles" on page 101, you
learn how to define a standard window for a variable.

Up until now, all variables are presented in measure windows and in identical lay-
out: the variable name display, followed by the corresponding numeric value. This
display type is appropriate for some variables, but you may want to display other
variables in a different format, e.g. in anOscilloscope or aMeasure table.

Oscilloscopes, for example, present the chronological progression of variables
graphically, thus allowing for a varied view of analog and digital variables in mul-
tiple display ranges.

To define during the variable selection in which window a variable is displayed

1. Select Variables > Variable Selection.

The Variable Selection dialog opens.

2. In the Sourceswindow, click on ETK-Testdevice:1.

3. From the variables list, select the following variables with the help of the fil-
ter:
B_LR

B_VL

TVLR

TVLRH

USVK

4. Delete your entries from the alphabetical filter.

5. In the toolbar, click on the following icon to check which variables are
added.

6. Press and hold <CTRL> and highlight the following variables:
B_VL

TVLR

TVLRH

7. In the context menu, select Add to > Layer_1 > New > YT-Oscilloscope.

8. Hold <CTRL> pressed and select the following variables:
B_LR

USVK
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9. In the context menu, select Add to > Layer_1 > Measure Window [1].

10. ClickOK.

Note

There are restrictions towards possible combinations of variable types for win-
dow types. A detailed description of all combinations and restrictions goes bey-
ond the scope of this tutorial. The online help of INCA describes which
combinations of variable types to window types are possible.

In the experiment, the variables are now distributed acrossMeasure window [1],
Measure window [2] and the YT-Oscilloscope. The YT-Oscilloscope enables a
more detailed view of the variables than the measure window. It is divided into an
analog (top) and digital (bottom) area and can be controlled using its toolbar.
The variables contained therein are located in the signal list (right).

As long as the experiment contains only a few elements, you can distribute the
variables via the context menu of the variables onto the respective windows as
outlined above. But this approach is generally very confusing for extensive exper-
iments. In this case, it is better to select the variables in the list of variables and
to arrange them in the Display Configuration.

6.3.4 Configuring the Display of the Experiment
To arrange the experiment via the display configuration

1. Select Variables > Variable Selection.

The Variable Selection dialog opens.

2. In the Sourceswindow, click on ETK-Testdevice:1.

3. Use the filters to select the following variables from the list of variables:
B_LR2

TVLRH2

TVLR2

4. Delete your entries from the alphabetical filter.

5. Click on the "Display Configuration" tab.
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In the Display Configuration area, you can see that the selected variables
are ordered below theMeasure window [3] entry.

6. Click on the new measure window.

In the tabular area you can see the properties of theMeasure window and
the variables it contains.

In more complex experiments, the windows can be organized in layers.
Therefore, the Experiment folder has a subfolder in the Display Con-
figurationwindow with the name Layer_1.

7. Press and hold <CTRL> and highlight the following variables in the tree view
in the "Display Configuration" window:
TVLR2

TVLRH2

8. Drag the variables TVLR2 and TVLRH2 fromMeasure window [3] to the
YT-Oscilloscope entry and deposit them there.

The variables were moved into the YT-Oscilloscope.

9. Click on the following icon in the toolbar to activate the filter for Boolean
variables:

In the Display Configuration area, all windows containing a Boolean vari-
able are opened and all other variables are hidden.

10. In the context menu for variable B_LR2 inMeasure window [3] , select
Cut.

11. In the context menu for theMeasure window [1], select Paste.

The variable is moved to theMeasure window [1].

12. In the context menu for the now emptyMeasure window [3], select
Delete.

Measure window [3] will be deleted.

13. Click on the following icon in the toolbar to deselect the set filter.

INCA V7.6 | Tutorial



6 Lesson: Setting Up an Experiment | 46

14. In the context menu ofMeasure window [2], selectChange Widget To >
Measure Table.

Measure window [2] is converted into a measure table-type window.

The conversion from a measure window-type window to a measure table-
type window can be recognized by the symbol preceding the window name

changing from to . The term "Measure window" in the tree structure
refers, however, to the name of the window and is therefore not altered by
INCA. That is why you rename your window to a more suitable name.

15. HighlightMeasure window [2] and select Rename in the context menu.
Then replace the current name with the new name,Measure table.

16. Move the following variables fromMeasure window [1] toMeasure table
[2]:
DTVKA

FRPS

RTV

USVK

17. Highlight Layer_1 and select Rename in the context menu. Then replace
the current name with the new name, Layer_Measure.

In the Display Configuration area you can see that the experiment now
contains the following elements:
l Layer_Measure
l Measure window [1]
l Measure table [2]
l YT-Oscilloscope [1]

Note

Elements that were selected in the variable selection, but have not yet
been added to the experiment, are identified by a gray bar.

18. ClickOK.

To change the display type of variables

1. In the Experiment Environment, select Variables > Display Configuration.

The Variable Selection dialog opens on the Display Configuration tab.

2. In the Display Configuration area, click onMeasure window [1].
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3. For each of the variables representing bits (those with names beginning
with B_):

a. In the Signals table, double-click on the cell of the corresponding vari-
able in the Display Type column.

A list of possible display types for the assigned window appears.

b. Change the setting from Numeric Display to Bit Display.

4. ClickOK to return to the experiment environment.

Note that the display of the bit signals inMeasure window [1] has
changed.

All settings for each variable can be changed in this way.
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To change the axis range for a variable in the YT-Oscilloscope

1. Right-click in the oscilloscope window and select Properties from the con-
text menu.

The "Variable Selection" window opens in the "Display Configuration" tab.
The tab displays the properties for the "YT-Oscilloscope" window.

2. For variable TVLRH:
a. In the Signals table, find the Range column, and double-click on the

TVLRH variable cell.

b. Replace the left value (the minimum y-axis value) with -500.

c. Click on the right value (the maximum y-axis value) and replace it with
500.

d. Confirm the changes with <ENTER>.

3. ClickOK to return to the experiment environment.

Observe the change to the y-axis for the TVLRH variable in the YT-Oscil-
loscope.

Note

You can also change the axis range using the scroll function of your
mouse. Move your mouse pointer over the desired axis and move it up or
down with the mouse button pressed or move the scroll wheel to scroll
the axis, and do the same with holding <CTRL> key pressed to change the
scale.

To change the color of a variable in the YT-Oscilloscope

1. Once again, right-click in the oscilloscope window and select Properties
from the context menu.

The "Variable selection" window will open on the "Display configuration"
tab.
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2. For the variables TVLR and TVLR2:
a. In the "Signals" table, find the "Color" column and double-click on the

TVLR variable cell.

A dialog window for color selection will appear.

b. Select a red color field and clickOK.

c. Using the same method, change the color of TVLR2 to a yellow color.

3. ClickOK to return to the experiment environment.

Observe the simultaneous change to the y-axis for the TVLR and TVLR2

variables in the YT-Oscilloscope.

To distribute variables in a YT-Oscilloscope across additional strips

1. For the variables TVLR and TVLR2:
a. Press and hold <CTRL> and highlight variables TVLR and TVLR2 in the

oscilloscope signal list.

b. Open the context menu in the oscilloscope window.

c. Select New Strip for Selected Variables.

The variables are moved to a new strip in the analog display area.
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To assign a shared axis to variables in the YT-Oscilloscope

Note

The first variable axis in the signal list is used as the shared axis. If necessary,
observe the order of the variables before assigning them to a shared axis. You
can change the order by clicking on a variable and dragging it to a new location
within the list using your mouse.

1. For variables TVLRH and TVLRH2:
a. Press and hold <CTRL> and highlight variables TVLRH and TVLRH2 in the

oscilloscope window signal list.

b. Open the context menu in the oscilloscope window.

c. SelectCommon Axis for Selected Variables.

The variables are now displayed together on a shared axis.

2. Do the same for TVLR and TVLR2 to display them on a shared axis.

3. In the experiment environment menu, select Experiment > Save.

The experiment is now saved and you can load it at any time by selecting the
OneETK workspace in the Database Manager and selecting Experiment >Open.
You can also load another experiment by selecting Experiment >Open in the
Experimentwindow.

INCA stores not only the variables, but also their formats and the exact size and
location of the windows in which they are displayed. Practice changing the size of
theMeasure window [1] and moving it. Re-save the experiment to apply the new
layout.
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6.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. All numerical variables must be displayed in the same window.
A. True

B. False

2. You can display several variables in a single "YT-Oscilloscope" window.
A. True

B. False

3. A workspace can have more than one experiment assigned to it.
A. True

B. False

6.5 Summary
You set up the LambdaControl experiment for the measurement task by select-
ing the variables to be measured, and changing their display formats. You also
changed the display range of a "YT-Oscilloscope" window. You changed the win-
dow layout and saved the experiment so you can load it later as a shortcut.
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7 Lesson: Measuring

Learning time: 45 minutes

7.1 Objectives
In this lesson you make measurements, and record the results. A Recorder Man-
ager is available, which helps you in managing individual recordings and starting
them according to current needs.

In this lesson, you will use the Recorder Manager to create one recorder for
manual recordings, one for recordings with fixed duration and one for automated
recordings. For the automated recordings, you will also specify triggers used for
starting and stopping the recording process.

7.2 Review of the Most Important Concepts

Measurement task

The state of the engine is assessed using sensors. A sensor measures an
engine parameter and makes the value available to the ECU as a number. The
measurement task consists of sampling all sensor values over a certain period
of time. It is also possible to record the sampled values in a file and save it to
disk. The resulting record documents the engine behavior for a certain set of
calibration values.

7.3 Tasks

7.3.1 Load the Lambda Calibration Experiment
The measurements applied in this lesson are used together with the experiment
you created in the preceding lesson. You can quickly restore the configuration in
the experiment environment by simply loading the experiment.

To load the Lambda calibration experiment

1. Select the OneETK workspace in the navigator field of the Database Man-
ager.

2. Select Experiment >Open.

The Experimentwindow opens, andMeasure window [1] and other meas-
ure windows are restored with the variables and layout you defined in the
previous lesson.

7.3.2 Start and Stop a Measurement without Recording
When you tell INCA to start measuring the measure variables displayed in the
Experiment environment are updated. The value fields of the numerically dis-
played variables turn into changing numbers and theOscilloscope window come
to life.
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To start measuring

1. SelectMeasurement > Start Visualization.

When using this feature routinely, it is more convenient to use the accelerator
key code <F11> to start a measurement.

To stop measuring

1. SelectMeasurement > Stop Measuring.

When using this feature routinely, it is more convenient to use the accelerator
key code <F9> to stop a measurement.

7.3.3 Analyzing Measurements in the YT-Oscilloscope
To analyze measurement data in a YT-Oscilloscope, you can stop their display
independently of experiment recording. When they are no longer displayed, it is
possible to move the time axis freely, to increase its display, and to assign
samples with a cursor.

Prior to recording, you can insert additional boundaries in order to visually high-
light bounds for measurements.

To stop displaying in the YT-Oscilloscope

1. Once again, start with a measurement. To do so, selectMeasurement >
Start visualization.

2. After a few seconds, find the oscilloscope window toolbar and click on
Play/Pause ( ).

This will stop the display in the oscilloscope window.
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Note

This does not stop the measurement. When reinstating the display in the
oscilloscope, the display position automatically jumps to the current
point in time of the measurement.

To move the time axis

1. Left-click on the time axis in the oscilloscope window and press and hold
the mouse button.

2. Move the mouse left or right.

The display scrolls depending on the mouse motion.

To increase the display size

1. In the oscilloscope window toolbar, click on Zoom in ( ).

The display will grow larger. The time axis scale will decrease accordingly.

2. Continue clicking Zoom in until you have reached the desired enlarge-
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ment.

To add a cursor

1. In the oscilloscope window toolbar, click onCursor ( ) > Add cursor.

A cursor will appear in the center of the time axis. In addition, a column is
added in the signal list which shows the signal values where the cursor is.

2. Double-click on the split bar left of the signal list to enlarge it and make the
additional column visible.

3. Move the mouse over the cursor until it is highlighted.

4. Drag the cursor to the desired location on the time axis.

Note

Observe the tool tips at the intersection of signals and cursor when the
latter is moved.
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To reinstate the display

1. In the oscilloscope window toolbar, click on Play/Pause ( ).

The display will be reinstated in the oscilloscope window. The time axis will
jump to the current point in time of the measurement.

To add a border line

Note

It is best to add a border line before starting visualizing the display of meas-
urement data. Otherwise, visualization will restart after it has been added.

1. Stop the measurement in progress. To do so, selectMeasurement >
StopMeasuring.

2. Right-click in the oscilloscope window and select Properties from the con-
text menu.

The "Variable Selection" window will open with the "Display Configuration"
tab.

3. Right-click in the "Border Lines" table and select Add from the context
menu.

A border line will be added as a row in the table.

4. Double-click in the Value column field.

A dialog box for entering boundary values will open.

5. In the Axis field, select the value A.

6. Enter 400.

7. ClickOK to return to the display configuration.
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8. ClickOK again to return to the experiment environment.

Observe the boundary in the TLVR and TLVR2 variable y-axis.

7.3.4 Create a Recorder for Manual Recordings
You are in the Experiment Environment. To create a recorder for manual record-
ings and start it subsequently, do the following:

To create the recorder

1. SelectMeasurement > Open Recorder Manager (Ctrl+F11).

The "Manage Recorders" dialog box opens.

2. SelectCreate new recorder (Ctrl+N) from the context menu.

A new recorder with the name Recorder is added to the recorder list.

3. Press F2 to rename the recorder to Recorder_Manual.

To add variables to the recorder

1. In the "Recorder_Manual" context menu, select the Add variables (Ins)
command.

The "Variable Selection" dialog opens.
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2. In the toolbar, click on the following icon to filter the variables that have
already been selected.

The variable list shows all variables that are already part of the experiment.

3. Select the following variables from the list:
l B_FRMIN

l B_FRMAX

l B_LR

l FLR_AP

l FR

l FRPS

l LR_I_Anteil

l LR_P_Anteil

l RTV

l TVLR

l TVLRH

l USVK

4. ClickOK.

The variables are now listed in the variables list of the recorder.
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To specify the file in which the recording is stored

1. Click on Recorder_Manual and selectOpen Recorder Configuration
(Enter) from the context menu.

The Recorder Configuration dialog appears.

2. Select the "Output File" tab.

3. In the "Path" field, enter <INCA base>\ETASData\INCA\Measure.

The "File" field automatically shows the name of the recorder.

4. If the fields Use date/time in file name and Auto increment file name are

not yet being displayed, click on to expand the view and display hidden
fields.

5. Replace the automatically assigned file name Recorder_Manualdat with
Tutorial.

6. In the Format field, select the yyyy-mm-dd entry.

For the next recording with this recorder, the current date is automatically
added to the file name of the new output file.

7. Activate the Insert default comment check box.

The default comment can be expanded with additional comment fields or
personal entries. All these data are saved with the measurements in the
file.

8. Click on Edit.

The Default Comment Editor dialog opens.

9. Hold <Ctrl> pressed and click on the following comment fields:
&[USER]

&[VEHICLE]

10. Click on the following button to move the selected comment fields from
the Available Comments column to the Used Comments column.

11. ClickOK.

For the next recording of the output file, the comment fields that have
already been used in the default comment and the comment fields &
[USER] and &[VEHICLE] are being entered.

12. Fill in the fields User,Company, Project and Vehicle.
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13. Disable the check box Show Output File Properties dialog after record-
ing.

To define the trigger conditions

1. In the "Recorder Configuration", select the "Triggers" tab.

2. Activate Trigger on.

3. Open the drop-down list in the Start Trigger field and select the entry
MANUAL.

Recorder_Manual starts if F5 is pressed during the recording.

4. ClickOK to go back to the Manage Recorders dialog.

To define event markers for the default recorder

Note

Use the event markers to manually identify events in the "Default Recorder" dur-
ing a measurement.

1. Click on Default Recorder and selectOpen Recorder Configuration
(Enter) in the context menu.

The "Recorder Configuration" dialog appears.

2. Select the "Recording" tab.

3. Enable the "Show Comment" check box.

4. In theComment field, enter Manual Event Markers.

5. ClickOK to go back to the "Manage Recorders" dialog.
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7.3.5 Make a Recording Using a Fixed Recording Interval
When specifying the recording interval you must choose between two different
modes of recording. You can either use a fixed recording interval, which is started
when you give the (manual) command to start recording, or you can automate
the recording by specifying a so-called trigger, which is a certain condition to
become true after you give the (manual) command to start recording. The two
modes are mutually exclusive.

First, do a recording using a fixed time interval.Fig. 7-1 shows the recording pro-
cess when using a fixed time interval.

Fig. 7-1: Recording process when using a fixed time interval.

To do a measurement using a fixed recording interval

1. Create a new recorder (see "Create a Recorder for Manual Recordings" on
page 57).

2. Rename this recorder to Recorder_Period.

3. Add the same variables as in the previous example (see "Create a Recorder
for Manual Recordings" on page 57).

4. Select the "Output File" tab in the Recorder Configuration.

5. In the Path field, enter <INCA base>\ETASData\INCA7.5\Measure.

6. Rename the output file to Tutorial2.

7. In the "Recorder Configuration", select the "Triggers" tab.

8. In the Recording Duration field, enter the value 30 seconds.

9. ClickOK to go back to the Manage Recorders dialog.

7.3.6 Creating a Recorder for an Automated Measurement
You can automate a measurement using triggers for starting and stopping the
measurement. A trigger is a mechanism that is automatically executed after an
event (such as starting the recording process). The trigger activates the meas-
urement when the outcome of a logical expression, the trigger condition,
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changes from false to true. Since the logical expression is a function of a meas-
ure variable it is really the value of the measure variable that causes the meas-
urement to start.

In the following example you specify the following trigger: start recording the vari-
ables measured in the current experiment setup as soon as the engine speed
exceeds 450 rpm.

To analyze the engine behavior before and after the transition marked by the trig-
ger event you need to record measurement values both before and after the trig-
ger event occurs. INCA enables you to do this by continuously storing the values
it measures in a buffer, even if you are not recording at the time. The time interval
to be recorded before the start trigger event happens is called pre start trigger
time. The interval that is recorded after the stop trigger event happens is called
post stop trigger time.

The relation between the pre start trigger time and post stop trigger time is illus-
trated in Fig. 7-2.

Fig. 7-2: Relation pre start trigger and post stop trigger times.

Instead of specifying a post stop trigger interval, you can also specify a trigger to
stop the measurement, for example engine speed to drop below 300 rpm.

To make a recording using a start trigger and a fixed duration

1. Create a new recorder (see "Create a Recorder for Manual Recordings" on
page 57).

2. Rename this recorder to Recorder_Trigger.

3. Add the same variables as in the previous example (see "Create a Recorder
for Manual Recordings" on page 57).

Note

You can also select recorder variables, copy them to a clipboard, and
insert them in other recorders.

4. Select the "Output File" tab in the Recorder Configuration.
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5. In the Path option, set <INCA base>\ETASData\INCA\Measure.

6. Rename the output file to Tutorial3.

7. Set Auto increment to 1 and click .

To define the trigger conditions

1. In Recorder Configuration, select the "Triggers" tab.

2. Activate the checkbox Trigger on.

3. Click on the button right of the Start Trigger drop-down list.

The "Trigger Editor" appears.

The trigger editor is used for defining trigger conditions. All existing trigger
definitions are collected in a list and can be set as start or stop triggers at
a later time.

4. In the Name field at the top of the dialog box, you can set a name for the
condition. This name can be used to define additional triggers. Change the
default name TriggerSignal to TVLRover450.

5. To select variables for the formula, click the following icon in the toolbar:

The "Variable Selection" Dialog opens.

6. In the Sourceswindow, click on All Sources so that all variables are dis-
played in the list of variables.

7. Then select the variable TVLR from the list and click onOK to go back to
the "Trigger Editor".

The variable name and the name of the device were entered in the Formula
field.

Now you want to enter an operator. The toolbox on the right of the editor
offers a large number of operators, grouped according to their type.

8. In the Toolbox, click the Relationship tab.

A list with operators that can be used for defining relations appears.
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9. Double-click the > operator to add it to the formula.

10. Click into the edit box of the Formula and type the value 450.

11. Click on Accept.

The trigger condition is entered in the Defined Triggers field.

All trigger conditions you have defined using different names are listed in
the Defined Triggers field. After collecting several conditions in this field,
you can later on quickly activate a certain condition as start trigger or end
trigger by selecting it in the Recorder Configuration on the "Triggers" tab.
The selected condition will then be used as the current condition for
recording.

12. ClickOK to go back to the Recorder Configuration.

13. In the Start trigger drop-down list, select the TVLRover450 trigger con-
dition.

14. In the Pre-Start Trigger Time (Sec) field, enter a value of 2 seconds.

15. In the Recording Duration (Sec) field, enter a value of 5 seconds.

16. ClickOK to go back to theManage Recorders dialog.

7.3.7 Perform Recordings
Depending on which recorders are enabled and which ones are disabled, you can
control which recording will be performed. Some functions such as opening the
Measure Data Analysis (MDA) after a recording is only available for the default
recorder. The default recorder can be renamed, but it cannot be deleted.
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To enable recorders

1. Start in the "Manage Recordes" dialog and select Recorder_Manual.

2. Select Enable Recorder (Space) from the context menu.

In the Enabled column, the symbol changes from to .

3. Select Recorder_Period.

4. Select Enable Recorder (Space) from the context menu.

In the Enabled column, the symbol changes from to .

5. Select Recorder_Trigger.

6. Select Enable Recorder (Space) from the context menu.

In the Enabled column, the symbol changes from to .

To start recording for all enabled recorders

You have two options for starting the measurement. Using the first method, you
can start all enabled recorders, including the default recorder; using the other
method, you can start all enabled recorders, excluding the default recorder.

You are in the Experiment Environment.

1. SelectMeasurement > Start recording (F12).

This initiates the following events:

a. *DefaultRecorder starts recording immediately.

b. Recorder_Manual waits for the manual trigger.

c. Recorder_Period starts recording immediately. After 30 seconds, the
recording of Recorder_Period stops. The recorded values are saved
in the output file Tutorial2.mf4. If a file Tutorial2.mf4 already
exists, it will be overwritten.

d. Recorder_Trigger waits for the trigger condition to be fulfilled. As
soon as the value of the variable TVLR exceeds 450, the recording will
be started.

2. Press the key F5 to start recording with Recorder_Manual.

To set an event marker in the default recorder

1. Press and hold <CTRL> + <K> to add an event marker to the default
recorder.

The "Insert User Comment" dialog box appears.
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2. Click onOK if you want to use the defined comment, or enter a new com-
ment.

The marker is inserted at the location in the recording file at which you
called the function and can be displayed for the measuring data analysis.

To stop the started recordings

The recording with Recorder_Period has already been automatically stopped
after 30 seconds. The recordings of Recorder_Period have been saved in the
file Tutorial2.mf4.

1. SelectMeasurement > Stop Measuring (F9).

This initiates the following events:

a. The recording of Recorder_Manual is finished. The recorded values
are saved in the output file Tutorialyyyy-mm-dd.dat (whereby
yyyy-mm-dd corresponds to the current date). If a file with this name
already exists, it will be overwritten.

b. The recording of Recorder_Trigger is finished. The recorded values
are saved in the output file Tutorial301.mf4 (this is the name
Tutorial3 with an appended two-digit number). If a file with the name
Tutorial301.mf4 already exists, the new file will be named Tutori-

al302.mf4.

c. The recording of *Default Recorder is being finished. The "Output
File Properties" dialog box opens.

2. Replace the automatically assigned file name in he File field with
Tutorial_default01.mf4.

3. You can amend the default comment with your own information as well as
personal information for the project. All these data are saved with the
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measurements in the file.

4. Click Save.

To start recordings for all enabled recorders apart from the default recorder

1. In the Experiment Environment, selectMeasurement > Start Visualization
<F11>.

The individual recorders react as described in the previous section.

2. Press the <F5> key to start recording with Recorder_Manual.

To stop the recordings

The recording with Recorder_Period has already been automatically stopped
after 30 seconds.

1. SelectMeasurement > Stop Measuring <F9>.

This initiates the following events:

a. The recording of Recorder_Manual is finished. The recorded values
are saved in the output file Tutorialyyyy-mm-dd.dat (whereby
yyyy-mm-dd corresponds to the current date). If a file with this name
already exists, it will be overwritten.

b. The recording of Recorder_Trigger is finished. The recorded values
are saved in the output file Tutorial302.dat. If a file with the name
Tutorial302.dat already exists, the new file will be named Tutori-

al303.dat.
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7.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. How many conditions can you define for a start trigger?
A. 1

B. 2

C. Many

2. How many conditions can be made to apply simultaneously for a start trig-
ger?

A. 1

B. 2

C. Many

3. If a stop trigger has been defined, the posttrigger time is ignored.
A. True

B. False

4. If a start trigger is activated, the recording duration setting is ignored.
A. True

B. False

5. Which command starts recording with the default recorder?
A. Start visualization

B. Start recording

7.5 Summary
In this lesson you measured the variables defined for the Lambda Control

experiment. You made a manual recording, a recording with fixed duration and a
triggered recording and saved all results into a file.
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8 Lesson: Calibration

Learning time: 80 minutes

8.1 Objectives
In this lesson you display and calibrate the calibration elements associated with
the Lambda control experiment. You learn to use and manipulate calibration data-
sets. For calibration you use tabular as well as graphical calibration editors, and
change single values as well as ranges of values.

For modifying several calibration variables and activating them at once, you will
learn how to work with calibration scenarios.

8.2 Review of the Most Important Concepts

Calibration task

It is the task of the ECU (Electronic Control Unit) to control the engine so it
exhibits a desired behavior. The ECU uses a feedback process to do this: it
measures the state of the engine using sensors, and then changes the state
of the engine towards the desired behavior using actuators. The new state is
measured and adjusted again and again, until an equilibrium is reached. Cal-
ibration is the process of adjusting the feedback parameters in such a way
that the car exhibits the desired behavior when the equilibrium state is
reached. Because the state of the car changes as it is driven, there are many
of these equilibrium states, usually called process points. A car is non-linear
system, and the control algorithm cannot rely on mathematics to determine
the feedback values. Instead it looks up the required actuator settings in a set
of tables, using the sensor values as lookup criterion. The calibration task con-
sists of setting the values in the tables. The same ECU can have different valid
sets of calibration values implementing a different behavior, one set for a fast
car, for example, and another set for an economical car.

Variables, measure variables, calibration variables (characteristics, curves,
and maps)

The term variable is used as a collective name for both measure variables and
all types of calibration variables.

In general, a measure variable is a value passed by a sensor, and can be used
as a lookup value for calibration variables. Moreover, it is possible to measure
derived or calculated characteristics, or, with corresponding settings, also cal-
ibration variables.

There are three types of calibration variables:
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A. Characteristics are fixed values used as constants by the ECU program
after they are adjusted during the calibration process.

B. The ECU uses look-up tables to determine the required value of an actu-
ator setting as a function of measure variables (see Calibration Task). If
one variable is used to look up one output value, the table is called a curve,
because it can be represented graphically as an xy-curve.

C. A look-up table using two or more measure variables to find one output
value is called a map, because of the analogy to an elevation map; think of
the input variables as the coordinates, and the output value as the elev-
ation of a certain location on the map.
Maps that derive the output value from three or more input values are
called multi-dimensional maps.

Process point

For any curve or map, the process point is the current lookup value passed to
the ECU. The process point changes with the value of the measure variable
used as lookup criterion into the curve or map. The process point can be visu-
alized on the map; in a tabular calibration editor the cell holding the current
lookup value is 'selected'. As the process point changes, the selection moves
across the cells of the table.

Dataset

The values making up the characteristics, curves and maps are stored in per-
manent memory in the ECU, and accessed by the ECU processor. A set of cal-
ibration values stored in the database is called a dataset. Datasets are
versioned; a certain version corresponds to a certain calibrated behavior. Data-
sets are stored in *.hex or *.s19 files and referenced in the database. These
files are binary images of the ECU memory, and beside the calibration data
they also contain the ECU program itself.

Calibration Scenario

Using the Calibration Scenario Editor, you can configure several calibration
scenarios within the Experiment Environment. Each scenario contains a set of
calibration variables. These can be calibrated individually from each other.
Afterwards you can easily activate complete scenarios on the ECU, i.e. when
switching to that scenario, a complete set of calibration variables gets mod-
ified on the ECU at once. This feature allows you to compare the behavior of
variables that belong together, thereby optimizing data in an efficient way.
Such a set of calibration scenarios including the corresponding settings is
called a calibration scenario configuration. In addition to that, it is also pos-
sible to save individual calibration scenarios in external files (e.g. CVX) for data
exchange.
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8.3 Tasks

8.3.1 Add Calibration Variables to the Experiment
To change calibration variables, they must be added to the experiment. The cal-
ibration variables are added in the same way as described for measurements in
Lesson: Setting Up an Experiment. The calibration variables are displayed in the
Experiment Environment in separate calibration windows, which are also called
editors.

In "Lesson: Setting Up a Workspace" on page 22 you loaded a master dataset to
initialize the project with calibration data. This means that when viewing cal-
ibration elements they have appropriate values.

Adding calibration variables to the experiment is done in the same manner as
adding measure variables. Some helpful hints:

In the "Variable Selection" dialog, the first symbol before the names of the
calibration variables always is a blue circle.

There is a filter you can use to select calibration elements in the variables
list of the "Variable Selection "dialog. Apply the filter by clicking the icon for
calibration variables in the toolbar of the "Variable Selection" dialog.

When selecting calibration variables in the "Variable Selection" dialog you
can mix characteristics, curves, and maps freely.

Using the skills you acquired in "Lesson: Setting Up an Experiment" on page 36 to
add the following characteristic values. Use the filters from the toolbar and the
alphabetic filter.

1. Add the following scalar arith. elements:
FRMAX

FRMIN

2. Add the following curve:
TSPERN

3. Add the following maps:
KFRP

KFRI

INCA V7.6 | Tutorial



8 Lesson: Calibration | 72

KFRTV

Note that the following editors have been added to the experiment:

Both characteristics are presented in theCalibration window [1]. The curve is
displayed in graphical and tabular form in theCombined Editor [2]. The maps are
presented in graphic and tabular form in theCombined Editor [3] . By setting a
different variable using the combo box at the top, you can switch maps in the
Combined Editor [3].

As you may have noticed by now, the experiment is very confusing. In the next
lesson, you will learn how to divide the display of the experiment into layers by
using the display configuration in the Variable Selection dialog.

To divide the experiment into layers

1. Select Variables>Display Configuration.

The "Variable Selection" dialog opens on the "Display Configuration" tab.

2. In the toolbar, click on the following icon to add a new layer:

3. Rename the new layer to Layer_Calibration.

4. Click onCalibration window [1], press and hold the <SHIFT> key and high-
light all windows down toCombined Editor [3].

5. SelectCut from the context menu.

6. Click on Layer_Calibration and select Paste in the context menu.
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7. ClickOK to adopt the settings and to return to the experiment envir-
onment.

In the bottom area of the experiment, the layers Layer_Measure and
Layer_Calibration can be selected via tabs.

8. Click on the Layer_Calibration tab.

9. Move and scale the editors so that all can be viewed very well.

8.3.2 Switch Between the Reference and Working Datasets
As you have seen in "Lesson: Calibration" on page 69, INCA keeps several copies
of the calibration data with the project: a reference and a working dataset, shown
in the project information as Reference Page RP and Working Page WP.

The reference page is read-only. You use it to compare the behavior of the
engine. Also, you may want to return to the reference dataset in case your cal-
ibrations do not work out as expected, and you want to reset the calibration.

The working page can be modified. This is the dataset you use to do calibrations.
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INCA allows you switch easily between the reference and working pages. You can
see whether you are using the reference or working page by watching the back-
ground of the calibration editor windows: if they are gray the reference page is
active, if they are white the working page is active.

To switch between reference and working page

1. Directly below the menu bar of the "Experiment" window you see a toolbar.
Near the center of the toolbar are two radio buttons, one labeledWP and
one labeled RP. The names of the corresponding datasets are displayed
right to the radio buttons; in this tutorial they are 0400_1 for the working
dataset and 0400 for the reference dataset.

2. Click the radio button labeledWP to switch to the working page.

3. Select Experiment > Save.

8.3.3 Download the Current Version of the Calibration Data to the
ECU
If a connection to the ECU is made, it is possible to access the calibration data in
its memory. Note that in a real setting the hardware typically contains a version of
the calibration data which is different from the data you loaded for the project. To
ensure that you are calibrating using the appropriate version of the calibration
data, you must transfer the calibration data to the ECU.

To download the current version of the calibration data to the ECU

1. Select Hardware > Hardware status.

Verify the hardware status to ensure that there is an active connection to
the ECU. Then close the hardware status view.

2. Select Hardware > Manage memory pages.
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The "Memory Page Manager" opens.

The Memory Page Manager allows you to perform several actions on the
calibration data. All actions involve moving calibration data from one place
to another. The Devices field shows all the ECUs in the current hardware
configuration, including the checksum calculation status. The set of radio
buttons in the Action field allows you to select the action to be performed.
The From and To fields list the possible source and destination locations of
the calibration data. The graphic in the center of the window summarizes
the action you are programming. It updates dynamically according to the
selections you make. Use the graphic to double-check that the pro-
grammed action is what you want to ensure that the hardware won't be
damaged when you actually move the data.

3. In the Action field, activate Download.

4. In the Apply to field, activateCode + Data.

5. In the From field, select Datasets.

6. In the To field, press and hold <CTRL> and select Working page+Code

page and Reference page+Code page.

7. Click Do It to start the action and clickClose to return to the experiment.

8.3.4 Show Process Point
Now that there is an active connection to the ECU, you can show the process
point on the curves and maps.

To show the process point on the TSPERN curve

1. In the context menu of theCombined editor [2], which displays TSPERN,
select Set Editor on Process Point.

2. SelectMeasurement > Start Visualization.
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Note that the process point is visualized in theCombined editor [2] with
the TSPERN map by a green frame around the table entry that corresponds
to the process point.

3. Stop measuring.

8.3.5 Perform the Calibration Task

WARNING

Calibration activities influence the behavior of the ECU and the systems con-
trolled by the ECU. This may result in unexpected behavior of the vehicle and
thus can lead to safety critical situations.

Now it is time to do the actual calibrations.

To calibrate the scalars

1. In the Experiment environment, ensure that the working page is active.

2. Select theCalibration window [1]with the characteristics FRMAX and
FRMIN.

3. Double-click the value in the edit box to the right of the parameter name
FRMAX.

4. All digits constituting the value in the cell are selected. Type 1.25 and
press <ENTER>. The setting is rounded to 1.2452, the nearest value avail-
able according to the description of the parameter in the project descrip-
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tion file.

5. Change FRMIN to 0.75 using the same method.

In the following exercise, you first enter new values for the TSPERN curve in the
table and then refine the calibration using the graphical display.

To calibrate the TSPERN curve

1. Maximize the window of theCombined editor [2].

2. Change the values in the cells using the same methods as for changing
parameter values:
x=0: z=0.5

x=100: z= 1.2

x=200: z=1.3

x=300: z=1.2

x=400: z=1.35

x=500: z=1.35

3. Change the value for x=500 by reducing the x-value from 500 to 450

The curve now appears in its new shape, according to the values you
entered in the table. Note that the curve is not smooth.

To smoothen the curve using the graphical area of the editor

1. Click the little triangle on the curve representing the value of TSPERN at
x=300.

A colored mark indicates you can now change the value for x=300.
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2. Drag the triangle to a new position on the chart so the curve looks smooth.

3. Restore theCombined editor to its normal size.

Entering the new values for all the entries in the TSPERN table was fairly time con-
suming. In order to facilitate the calibration task INCA allows you apply changes
to an entire range of values using a single command. In the following exercise you
apply three such changes to ranges of map values.

Note

When calibrating the arith. elements, also consider the Diff counter in the
upper area of the experiment. It counts the total number of performed changes
in bytes, thus allowing a quick overview of the differences between the ref-
erence and working page.

To calibrate all values of a map

1. Select the KFRTV map in theCombined editor [3] and maximize this win-
dow.

2. Select one value in the map table.

3. Select Edit > Select All Values to select all table entries.

4. In the context menu of the marked entries, select Add Offset.

The "Add Offset" dialog appears.

5. Enter 0.2 in the edit box and clickOK to go back to theCombined editor.
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All values were increased by 0.2.

To fill a map with a value

1. Select the KFRI map in theCombined editor [3].

2. Select all values with y=1.5 by dragging the mouse over the appropriate
cells while keeping the left mouse button depressed.

3. In the context menu of the selected values, select Fill With Values.

The Fill with value dialog appears.

4. Enter 0.8 in the edit box and clickOK to go back to theCombined editor.

All values in the selected series were set to 0.799

To multiply values in the map with a single value

1. In theCombined editor [3], select the KFRP map.

2. Select all values with x=1000 and x=1400 by dragging the mouse over the
appropriate cells while keeping the left mouse button depressed.

3. In the context menu, selectMultiply by Factor.

The "Multiply by factor" dialog opens.

4. Enter 1.1 in the edit box and click OK to go back to theCombined editor.
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All selected values were increased by 10%.

5. Restore theCombined editor to its normal size.

8.3.6 Save the New Calibration Dataset
The changes to the calibration elements are automatically saved as soon as you
make them.

At this point, all you need to do is save the experiment to retain the calibration
windows for future use.

But if you are making changes to a group, you should document your work and
save the dataset of changes in a file exchange format.

You will learn how to do that in Lesson: Managing Calibration Datasets.

8.3.7 Edit Several Calibration Variables and Activate them at Once
You can use calibration scenario configurations to edit several variables and activ-
ate them at once. In contrast to the procedures used in the previous section,
modifications of calibration values are not automatically saved and applied.

To create a new calibration scenario configuration

1. In the "Variables" menu of the Experiment Environment, select the New Cal-
ibration Scenario Configuration command.

The "Calibration Scenario Editor" opens.

2. In the menu, select the Add Variables command.

The "Variable Selection" dialog opens.

3. Select the following variables:
FRMAX

FRMIN

TSPERN

KFRP

KFRI
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KFRTV

4. ClickOK.

The variables are added to the calibration scenario configuration.

To create an external calibration scenario

1. In the "Scenario" menu, select New scenario.

A new scenario with the name Scenario-01 is created.

2. In the "Save" menu, select Save configuration.

3. Select Rename scenario from the context menu of the new scenario.

The "Rename scenario" dialog box opens.

4. Enter CalScen_Data as its new name.

5. ClickOK.

To edit the calibration variables

1. Verify that the working page is enabled (see "Switch Between the Refer-
ence and Working Datasets" on page 73).

2. In the CalScen_Data column, click on the value of the variable FRMAX.

In the lower part of the window, the editor which is used for editing the cal-
ibration values is displayed.

3. Click on the value in the editor.

4. SelectMultiply by Factor in the context menu.

The "Multiply by Factor" dialog box opens.

5. Enter the value 1.1.

6. ClickOK.

The selected value is multiplied by 1.1.
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7. In the CalScen_Data column, click on the value of the variable FRMIN.

In the lower part of the window, the editor which is used for editing the cal-
ibration values is displayed.

8. Click on the value in the editor.

9. Select Divide by a Divisor in the context menu.

The "Divide by a Divisor" dialog box opens.

10. Enter the value 1.2.

11. ClickOK.

The selected value is divided by 1.2.

12. In the CalScen_Data column click on the value of the variable KFRI.

In the lower part of the window, the editor which is used for editing the cal-
ibration values is displayed.

13. Maximize the window of the Calibration Scenario editor and scale the
graphic so that you can recognize it.

14. SelectOptimize Column Size from the context menu of the table,.

The columns of the table are adjusted accordingly to the size of the values.

15. Click on the first value and press <CTRL + A> to mark all values.

16. Select Add offset from the context menu.

The "Add offset" dialog box opens.

17. Enter the value 0.1.

18. ClickOK.

The value 0.1 is added to all selected values of the map.
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19. In the CalScen_Data column click on the value of the variable KFRTV.

In the lower part of the window, the editor which is used for editing the cal-
ibration values is displayed.

20. In the editor select the values in the first three columns.

21. Select Increment from the context menu.

All selected values are incremented by a preset value.

You have now finished editing the calibration variables.

22. In the Save menu select Save configuration.

To activate the edited scenario

1. Restore theCalibration Scenario Editor to its normal size.

2. Click in the CalScen_Data column.

3. Select Activate scenario from the context menu.

Observe the values in the editors of the experiment, they are changed by
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activating the calibration scenario.

The values of the calibration scenario are directly copied to the working
page.

Note

When you perform the calibration task online, the values are enabled on the
ECU immediately upon activating the scenario.

To store the scenario as an external file

1. Click in the CalScen_Data column.

2. Select Save scenario as from the context menu.

The "Save as" dialog box opens.

3. Enter CalScen_Data for the file name.

4. Select CVX files (*.csv) for the file format.

5. Click Save.

6. Close the experiment to return to the database management.

A confirmation dialog appears asking whether the original values for the
working page should be restored.

7. Respond with No.

Note

Only those calibration variables that are part of the scenario are written to the
data exchange file. If you save the external scenario in an existing file, all pre-
viously saved variables get deleted.
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8.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. How many curves can you calibrate in a single combined editor in 3D dis-
play?

A. 1

B. 2

C. Many

2. How many parameter values can you calibrate in a single operation?
A. 1

B. 2

C. Many

3. How many map values can you change in a single operation?
A. 1

B. 2

C. Many

4. Which of the following descriptions best describes changing the display
format of a calibration element?

A. Use the menu of the calibration editor to get a list of dis-
played calibration elements and their format settings.
Change the setting for the appropriate calibration ele-
ment.

B. Move the calibration element to a new window. Before
the new window is displayed, you can set the format to
the desired format.

C. Right-click the element and select the desired format
from a context menu.

8.5 Summary
In this lesson you added the calibration elements for the Lambda control exper-
iment to the Experiment window. You know the difference between reference
and working page. You calibrated characteristics, a curve, and some maps by
applying changes to both individual values and ranges of values.

Moreover you have created a scenario by means of the Calibration Scenario
Editor in order to activate several calibrations at once. You have saved the cal-
ibrated variables in a data exchange file to be able to use them elsewhere.
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9 Lesson: Managing Calibration Datasets

Learning time: 45 minutes

9.1 Objectives
You can use the Calibration Data Manager for managing calibration datasets. You
document your calibration task, save the results in a data exchange file, compare
different datasets and merge different datasets into a new reference dataset.

9.2 Review of the Most Important Concepts

Calibration Data Manager (CDM)

TheCDM allows you to manage and analyze datasets that have been gen-
erated during a calibration task.

In theCDM it is possible to list, copy and compare complete datasets or their
contents.

Dataset

The values making up the characteristics, curves and maps are stored in per-
manent memory in the ECU, and accessed by the ECU processor. A set of cal-
ibration values stored in the database is called a dataset. Datasets are
versioned; a certain version corresponds to a certain calibrated behavior. Data-
sets are stored in *.hex or *.s19 files and referenced in the database. These
files are binary images of the ECU memory, and beside the calibration data
they also can contain the ECU program itself.

Data exchange file

Files in a data exchange format allow you to provide the datasets that have
been created in a calibration task for being used in other programs or by other
users.

9.3 Tasks
When performing calibrations over the course of a project it is useful to be able to
manipulate and compare different versions of the calibration dataset you are
working on. With theCDM you are able to perform these tasks. TheCDM can be
started from the Database Manager, and runs in its own application window, just
like the Experimentwindow.

For working in theCDM, you can distinguish between two main use cases. For the
calibrator it is useful to document his work and save it to a data exchange file.
The task of the responsible calibrator consists of merging the different cal-
ibration datasets into a new dataset.
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The CDM offers three main possible actions: List, Compare, and Copy. All three
actions which you can perform with the CDM have similar user interfaces. It is
best to start the CDM and look at its layout.

9.3.1 Start the Calibration Data Manager
To start the Calibration Data Manager (CDM)

1. In the "Database Manager", select Utilities >Calibration Data Manager

or

2. click .

or

<CTRL>+<F11>.

The "CDM" opens.

3. In the Action drop-down list, select List.

The Action field in the top-right corner of theCDM shows for which action
it is configured. The labels of the buttons at the bottom right of the window
change accordingly. Now it is displaying List.

The result of an action is always a file. The file path is displayed in the title
bar. If you generate a new configuration, INCA generates this path auto-
matically by using the system variable ${EcuProjectPath}\.

4. Click on Browse.. to select a permanent directory for your output files.

The Directories dialog appears.

5. Browse to the ..\ETASData\INCAx.y\CDM\.. directory.

6. ClickOK.

7. In the fieldOutput base name, enter Tutorial and click <ENTER>.
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The result file path in the title bar has changed to reflect the changes you
made.

To be able to use a single file path for output files with the same name,
INCA adds an action control code to the file name, e.g. Tutorial_
CPY.TXT. The action control codes are _LST, _CPY and _CMP for the copy
and compare actions, respectively.

Select the Copy option from the Action list field and look at the changes to
the output file name in the title row.
INCA added the action control code _CPY to the name.

8. Change back to the List action.

The Format field below the Action field specifies the output format for the
file to which INCA exports the result of the action. Selecting a certain
format determines the extension of the output file.

9. Click the arrow button of the Format combo box, and select HTML from the
drop-down list. Observe the changes to the output file name in the title
row. The file name should now read <INCA

base>\ETASData\INCA\CDM\Tutorial_LST.HTM.

The Variables to process group below the Format field contains a list box
with the variables the action is applied to. The label above the list box
shows how many variables of a total number of variables available in the
project are selected for the action.

To select a source dataset

1. Select Datasets > Select source dataset.

The "Select source dataset" dialog appears.

2. Expand the tree structure of the Tutorial database and navigate to the
folder Project _0400. Select the project 0400.

The datasets 0400 and 0400_1 appear in the right half of the dialog in the
Datasets field.

3. Select the 0400_1 dataset in this field, then clickOK to get back to the
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CDM.

To add variables

1. Select Variables > Add.

The "Variable Selection" dialog opens. Further information on the Variable
Selection dialog can be found in "Lesson: Setting Up an Experiment" on
page 36.

2. Using the procedures that you learned in "Lesson: Calibration" on page 69,
select the following calibration variables:
FRMAX

FRMIN

TSPERN

KFRP

KFRI

KFRTV

3. ClickOK to return to theCDM.

The fields List source and All datasets in theCDM define the datasets that
serve as source and destination for the action to be performed. Their use
depends on which action is performed, and is explained below, in the sections
dealing with the individual actions.

The Results group in the bottom-left corner contains six custom controls that
look like LEDs. Each of these controls reports on a specific aspect of the per-
formed action, e.g. errors or warnings. The number to the right of the LED indic-
ates how many errors, warnings, etc. were reported for the aspect related to the
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control. The status of these controls is continually updated as the action pro-
gresses. Click any of the LED controls to review details about the aspect related
to the control.

9.3.2 Compare Calibration Datasets
In order to retrace which variables have been modified by the calibrator in his cal-
ibration task and in which way, the CDM can show the differences between ref-
erence dataset and calibration dataset using theCompare function.

To compare the reference dataset with your calibration dataset

1. In the Action drop-down list, select Compare.

2. From the Format list field, select the HTML entry.

3. In the window area "Comparing destination", select the entry Add dataset
from the context menu.

The dialog box "Select destination dataset" opens.

4. Select the dataset 0400 as destination dataset and clickOK.

5. In the Variables to processwindow, select Add all from the context menu.

6. In the bottom part of the window, change the entry for theOutput base
name to Tutorial_compare.

7. Click onCompare all.

In the "Results" window in the lower left, you can see that differences
between source and target were found for twelve variables.

8. Click on the red controls and view the reports on the individual results.

9. Close the reports.

10. Click on View to open the results file.

The "Open File" dialog opens, showing all files in the working directory
<Inca base>\ETASData\INCA\cdm.

11. Select the file Tutorial_compare_CMP.HTM.

12. ClickOpen.

Your web browser is launched, showing the compare results. Modified cal-
ibration variables are displayed in red in the HTML file.

13. Close the web browser.

Note

You can also call up the application data manager directly from within an
experiment. Steps 1. to 6. in this tutorial are then automatically per-
formed for the reference and working pages of the experiment. See our
online help for additional information about this process.
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9.3.3 List Calibration Datasets
With the List action you can document all modifications that result from your cal-
ibration task.

As an example, it can be useful that all calibrators use the List action in order to
write their calibration datasets into an external file and give it to the responsible
calibrator. To ease the task of the responsible calibrator, you can write only the
variables into the file that have actually been modified.

To list the calibrated variables

1. In the Action drop-down list, select List.

2. In the Format drop-down list, select CDF.

3. Make sure that in the List source list box, 0400_1 is still selected as
source dataset and that in the dataset list below the reference dataset
0400 is used.

4. In the context menu in the "Variables to process" window, select the
Select/show all differences entry.

The list of variables is reduced to all those variables that are different in the
two datasets.

5. Change the entry in the fieldOutput base name into Tutorial_list.

6. Click on the List all button at the bottom right.

7. You can see in the "Results" window area at the bottom on the left that a
new results file has been generated.

9.3.4 Copy Calibration Datasets
The task of the responsible calibrator consists of collecting the calibration data-
sets from the individual calibrators and merging them in a new dataset. For this
task he needs theCopy action. In this task it is advantageous to create a new
destination dataset by copying the reference dataset. In a subsequent step, the
calibrations performed by the calibrators can be integrated, and the responsible
calibrator can write-protect the new dataset to prevent further modifications in
this dataset.

To copy the calibrations into a new dataset

1. In the Action drop-down list, select Copy.

2. In the Format drop-down list, select ASCII.

3. Select Datasets > Read source from file > Read from file.

or

Right-click in the "Copy Source" window area and select Read from file
from the context menu.

The dialog box "Open data exchange file as source" opens.

4. Select the file Tutorial_list.cdfx.

5. ClickOpen.
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A dialog opens.

6. Click onOverwrite.

The list box "Copy source" now shows the file Tutorial_list.cdfx.

7. In the context menu of the destination dataset 0400 select Remove.

8. Select Datasets > Add destination dataset.

The dialog box "Select destination dataset" opens.

9. Expand the tree structure of the Tutorial folder and navigate to the
folder Project _0400. Select the project 0400.

the datasets 0400 and 0400_1 are displayed in the Datasets list box in the
right half of the dialog.

10. SelectCopy from the context menu of the dataset 0400.

11. Select Paste from the context menu of the Datasets list box.

A new dataset named 0400_2 is generated and added to the list of data-
sets. The dataset is selected.

12. ClickOK to return to the CDM.

In the following steps you can use the new datasets for copying the cal-
ibrated variables into it.

13. Select Add all from the context menu of the Variables to process list box.

The six variables that have been calibrated as well as auxiliary variables are
added to the list box.

14. Change the entry in the fieldOutput base name into Tutorial_copy.

15. Click on theCopy all button in the lower right.

The "Results" window (bottom left) displays that there are 225 new vari-
ables. These are the additional calibration variables in the target dataset,
but not in the CDFX file.

16. Click on the red controls and view the reports on the individual results.

17. Close the reports.
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If the new dataset is okay, set it to write-protected. This will prevent any unin-
tended changes. Moreover you can use it as a new reference dataset for further
calibration activities.

To activate write-protection for a dataset

1. Select Freeze working data from the context menu of the destination
dataset 0400_2.

A dialog box opens which prompts you to enter a name for the write-pro-
tected dataset.

2. Enter 0410 and press <Enter>.

The dataset is now protected against further modifications. Since a write-
protected dataset cannot be modified, a new destination dataset 0410_1
has been created.

To copy the contents from further data exchange files, replace the file in the
Copy source list box by the desired data exchange file and repeat the copy
action.

It is possible to apply actions in the Calibration Data Manager to several des-
tination datasets at once.

For exercise purposes, compare the dataset from an application engineer with
the original reference dataset and your newly created reference dataset.

To compare two destination datasets with a source dataset

1. In the Action drop-down list, select Compare.

2. In the Format drop-down list, select HTML.

3. Select the dataset 0400 as source dataset.

4. Select the not write-protected dataset 0410_1 as your first destination
dataset.

5. Select Datasets > Read destination from file > Read from file.

6. In the <INCA base>\ ETASData\INCA7.5\cdm path, select the data
exchange file Tutorial_list.cdfx as the second target dataset.

7. Click onOpen.

The data exchange file gets added to theComparing destination list box.

8. Select Add all from the context menu of the Variables to process list box.

9. Change the entry in the fieldOutput base name into Tutorial_com-

pare_2.

10. Click onCompare all.

The "Results" window area at the bottom on the left shows the results of
the compare action.

11. Click on the red controls and view the reports on the individual results.

12. Click on View to open the results file.
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9.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. Which of the following actions can be performed using theCDM?
A. Database import.

B. Copying a dataset.

C. Writing calibrations of variables into an HTML file.

D. Database export into a CVX file.

E. Listing all calibration variables and their values into a
CVX file.

2. Which actions are available in the Actions field of the CDM?
A. Copy, list, compare.

B. Export, Import.

C. Add, remove, duplicate.

3. Which dataset will be overwritten in a copy action?
A. Source dataset.

B. First destination dataset.

C. Second destination dataset.

9.5 Summary
In this lesson you have learned how you can use the Calibration Data Manager
and its actions to manage and edit your calibration datasets.
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10 Lesson: Data Management

Learning time: 25 minutes.

10.1 Objectives
You can use the Calibration Data Manager for managing calibration datasets. You
document your calibration task, save the results in a data exchange file, compare
different datasets and merge different datasets into a new reference dataset.

10.2 Review of the Most Important Concepts

Dataset

The values making up the characteristics, curves and maps are stored in per-
manent memory in the ECU, and accessed by the ECU processor. A set of cal-
ibration values stored in the database is called a dataset. Datasets are
versioned; a certain version corresponds to a certain calibrated behavior. Data-
sets are stored in *.hex or *.s19 files and referenced in the database. These
files are binary images of the ECU memory, and beside the calibration data
they also contain the ECU program itself.

Database Objects

Database objects are all elements of the INCA database that are listed in the
Database Objects list box. Examples are workspaces, experiments and pro-
jects.

10.3 Tasks
In this lesson you export the data you created in INCA and import them into a new
database. You learn how to manage your data within the database.

10.3.1 Export the Database
When exporting the database, the data as well as the folder structure are written
to a file.

To export the database to a file

1. In the Database Objects field of the Database Manager, select the
Tutorial folder.

2. Select Edit > Export.

3. The "Export options" dialog appears. Make sure the two check boxes are
unchecked and clickOK.
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4. The "Export file" dialog appears. Change the file name in the File name field
to Tutorial-copy.exp64.

5. Click Save to export the file and to return to the "Database Manager".

10.3.2 Create an Empty Database
Using the skills you acquired in Lesson: Creating the Database, create a new
empty database called Tutorial-copy containing only an empty DEFAULT top
folder.

10.3.3 Import the Exported Database into the Empty Database
You now import the data you exported before into the empty database. The
import function automatically creates the folder structure present in the data-
base you exported from, so that you do not have to set it up before doing the
import. When setting up a database for a new ECU which is similar to an ECU you
have already used in the past you can use this mechanism to jump start your pro-
ject: import the old project and make the necessary adjustments, rather than
starting from scratch.

To import the data

1. In the Database Manager, select the DEFAULT folder of the Tutorial-
copy database.

2. Select Edit > Import.

The "Import Options" dialog appears.

3. Click on the following button:

A dialog window for the file selection appears.

4. Navigate to <INCA base>\ETASData\INCA7.5\Export and select the
file Tutorial-copy.exp64, which you previously created during the
export of the Tutorial database, and click onOpen.
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5. You get back to the "Import file" dialog. Make the following settings:

l Deactive the option Replace objects with same object ID. This makes
sure that the imported objects will be inserted as copies of the original
objects, even if the original objects are part of the database.

l Activate the option Import in selected path of database. This makes
sure that the imported objects will be placed into the selected folder.

l Activate the option Keep folder structure from the export file. This
makes sure that the original folder structure will be kept, instead of pla-
cing the objects flat into one folder.

6. ClickOK.

7. The Import dialog box appears. Make sure all entries in the list box are
selected and clickOK.

8. The "Import results" dialog appears, listing the items that have been impor-
ted. This dialog is for your information only; no action is required. ClickOK
to return to the Database Manager.

The imported items are created in the Tutorial-copy database. The folder
structure is the same as the folder structure of the tutorial database.

Using the import and export function of the Database Manager, you cannot only
write complete databases to an export file, but also individual database objects
such as workspaces, experiments, projects and datasets. Moreover, it is possible
to reuse elements of experiments such as layers and measure and calibration
windows within the INCA database or to export and import them.

Note

Further information on the export and import functionality is provided in video
tutorials which you can access via the INCA help menu: ? > Video Tutorials.

10.3.4 Reuse Elements of Experiments
When working with INCA, it is often useful to reuse parts of your work.
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To reuse elements of an experiment in a new experiment

1. Add a new experiment to the Experiment folder in the Database Objects
list box.

2. Rename the new experiment into Ignition.

3. Select the experiment LambdaControl.

The Experiment Elements list box lists all layers as well as all measure and
calibration windows that are used in the LambdaControl experiment.

4. Mark theCombined Editor [3] and theMeasure Window [1].

5. SelectCopy from the context menu.

6. Click on the experiment Ignition.

7. Select Paste from the context menu in the Experiment Elements list box.

A new layer and the measure and calibration windows that you copied are
added to the experiment Ignition.

10.3.5 Manage Database Objects
Your daily calibration work might include creating different calibration datasets
for the same calibration task, all of them being derived from the same reference
dataset. As an example, this can be the case if there are different requirements
for the European and the American markets. In this case, you can organize your
work by moving the two datasets into different folders.

To organize your datasets

1. In the Database Objects list box, expand the tree structure of the folder
Project_0400.

2. Select the project 0400.

The Datasets list box list all datasets that you have created in this tutorial.

3. Rename the folder 0400 into EU.

4. Select Add top folder from the context menu of the Datasets list box.
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5. Rename the new top folder into US.

6. Mark the datasets 0410 and 0410_1 that you created in the previous
"Lesson: Managing Calibration Datasets".

7. SelectCut from the context menu.

8. Select Paste from the context menu of the folder US.
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10.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. Which of the following elements are stored in the file resulting from a data-
base export?

A. Project hardware configuration

B. Folder structure

C. Experiment window layout

D. Project master dataset

E. Project working dataset

F. Changes to the calibration elements

2. How can you reuse database objects within the Database Manager?
A. Drag the database object to another place.

B. Copy and paste a database object.

C. Export and import a database object.

3. How should a database be structured?
A. Top folder > Workspace, Experiment, Project

B. Top folder > Subfolder > database object

10.5 Summary
In this lesson you exported a database and reimported it into a new database.
Moreover you learned how to reuse database objects and elements of exper-
iments.
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11 Lesson: Settings and user profiles

Learning time: 15 minutes

11.1 Objectives
In this lesson, you customize several settings in INCA, and save them in a user
profile.

You also learn how to exchange user-specific settings with colleagues using the
import and export function.

11.2 Review of the Most Important Concepts

User profile

A user profile is a collection of settings for a certain user determining the look
and feel of the INCA user interface. A profile can be saved and loaded
between sessions. This allows users to configure the INCA user interface set-
tings to fit their requirements. Profile settings include start behavior, window
size, window arrangement, paths and many more.

11.3 Tasks

11.3.1 Enable the Use of User Profiles
By default the use of user profiles is disabled. To be able to use user profiles, the
use of user profiles must be enabled in the station options.

To enable the use of user profiles

1. Select Options > Station options from the "Database Manager".

The "Station options" dialog appears.

2. Click the cell to the right of the cell with the value User selection.

3. Click the same cell again.
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4. A list with the options Yes and No appears. Select Yes to enable the use
of user profiles, and clickOK to go back to the "Database Manager".

11.3.2 Create a New User
A user profile is always associated with a user. You can define users in any way
you like. A user can be a person, but you can also make user profiles for groups, or
even for different tasks by the same user.

To create a new user

1. SelectOptions > User > Add.

2. The Enter the new user title dialog appears.

3. In the edit box, type Student as the name for the new user whose profile
you are creating. Note that the profile name is the name of the user; you
cannot have more than one profile for a user.

4. ClickOK to create the new user profile and to go back to the "Database
Manager".

11.3.3 Change to the New User Profile
You can only change the profile of the current user. Therefore, before cus-
tomizing the profile, you must first change to the user you created in the pre-
vious section.

To change to the newly created user

1. SelectOptions > User > Change.

2. The Select the title you want to change dialog appears.

3. All users known to INCA are listed. Select Student and click onOK to
return to the "Database Manager".

11.3.4 Making Changes to a User Profile
When newly created, the user profile is a copy of the default user profile.
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To start the user profile editor

1. SelectOptions > User Options > Open.

2. The User options dialog appears. The settings in this dialog make up the
user profile.

Select the tabs to get an overview of the various possibilities. In the remainder of
this section you change several of these settings as an exercise.

First, change the appearance of INCA. You change a font properties and disable
maximizing of windows so new windows you open are not automatically max-
imized. Note that all settings you make in the user profile change the appearance
of all INCA windows.

To change the appearance of INCA

1. Select the Experiment tab from the User options dialog.

2. A list with several options appears. Click the cell to the right of the cell with
the value Adjust font in the variable views if the view

size is changed.

A list with the options Yes and No appears.

3. Select No.

With this setting you have defined that in standard measure windows in the
Experiment Environment, only fixed font sizes are used which do not depend
upon the window size.

4. Select the General tab.

5. Using the same method as before, change the setting for Maximized win-

dows to No.

Another change that could be useful if you usually calibrate calibration elements
of a certain type is to change the type of calibration editor that is used directly
after you select the element in the Variable Selection dialog. In this exercise,
you define the Table Editor as Default Calibration Editor for arithmetic values.
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To change the default calibration editor type

1. Click the Experiment tab.

A list with several options appears. The entries enclosed in brackets in the
Value column indicate that there is a list with further options behind the
cell.

2. Click the cell to the right of the cell with the value Calibration.

3. Click the same cell again.

The "Change of calibration options" dialog appears with a list of general cal-
ibration options.

4. Click the General tab. Click the cell to the right of the cell with the value
Default Scalar Editor.

5. Click the same cell again.

A list with possible editors for scalars appears.

6. Select Calibration Window from the list.

Every arithmetic value selected for calibration is now being displayed in a
Calibration Window.

7. ClickOK to go back to the "User options" dialog.

8. ClickOK to close the "User options" dialog.

Export your user profile to forward your user options to colleagues.

To export user options

1. SelectOptions > User Options > Export.

2. The "Export user settings" dialog appears.

3. Go to the directory <INCA base>\ ETASData\INCA7.5\Data\Demo.

4. In the File name field, enter INCAoptions_<Name>.zip and click on
Save.

11.3.5 Importing User Options
You can use the user options of a colleague by using the import function.
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To import user options

1. SelectOptions>User Options > Import.

The "Import user settings" dialog appears.

2. Go to the directory <INCA base>\ ETASData\INCA7.5\Data\Demo.

3. Select the INCAoptions_<Name>.zip file and click onOpen.
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11.4 Questions
Answer the following questions to test your understanding of the subject matter
presented in this lesson.

1. An entry enclosed in brackets (< >) in an option table means there is no
value assigned to the setting.

A. True

B. False

2. When creating a new user profile all settings are empty.
A. True

B. False

3. Arrange the following steps in the correct order:
A. Change to a new user

B. Turn on theOne file for each item setting

C. Click the "Export Import" tab

D. Save the user profile

E. Enable the use of user profiles

F. Create a new user

4. How many user profiles can you define?
A. 1

B. 2

C. Many

5. How many user profiles can you define for one user?
A. 1

B. 2

C. Many

11.5 Summary
You created a new user and created a profile for this user. You imported user
options of a colleague. You familiarized yourself with the various user options you
can use for customization. You customized the profile by changing the appear-
ance of INCA and changing the default calibration editor for arithmetic values.
You saved and exported your user profile.
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12 Answers

12.1 Lesson: Creating the Database
1. False

2. B,C,A

12.2 Lesson: Setting Up a Workspace
1. True

2. A, D, E

3. A = Hardware Configuration Editor
B = Hardware Configuration Editor
C = Hardware Configuration Editor
D = Database Manager
E = Database Manager

12.3 Lesson: Setting Up an Experiment
1. False

2. True

3. False

12.4 Lesson: Measuring
1. Many

2. A

3. False

4. False

5. B

12.5 Lesson: Calibration
1. Many

2. A

3. Many

4. None

12.6 Lesson: Managing Calibration Datasets
1. B, C, E

2. A

3. B, C
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12.7 Lesson: Data Management
1. A, B, C, D, E, F

2. B

3. B

12.8 Lesson: Settings and User Profiles
1. False

2. False

3. Steps should be in the following order:
Enable the use of user profiles>
Create a new user>
Change to a new user>
Click the "Export Import" tab>
Turn on theOne file for each item setting>
Save the user profile

4. Many

5. A
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13 Further Reading

Unless otherwise stated, the following additional documents are provided with
the basic INCA installation and can be found in one of the INCA folders Manuals
or Help. Further documents might be provided with INCA add-on products.

Documentation for Standard Users
INCA Help (available through INCA 1) )

INCA Getting Started

INCA Video Tutorials2)

Documentation for Special Use Cases
Serial (X)ETK Calibration Concepts — Limited Emulation RAM

Serial Calibration with InCircuit2

Documentation for Tool Integration
INCA ASAM-ASAP3 Interface

INCA ASAM-MCD-3MC V1.0.1 Interface

INCA Tool-API Documentation (help)
cebra\INCA Tool-API Documentation.chm3)

Documentation for Suppliers
ECU Document Interface (EDI) for INCA (PDF)4)

Specifications
CVX (Calibration Values Exchange)5)

CDF (Calibration Data Format) 6)

1) The INCA Help is automatically installed together with INCA and can be accessed via the INCA?
menu or by pushing F1.

2) The INCA video tutorials can be installed together with INCA (optional) or viewed in the ETAS
YouTube channel. You can access an overview and the videos themselves via the INCA?menu.

3) The Tool API documentation is automatically installed together with the Tool API component and
can be accessed by double-clicking the help file.

4) This document can be obtained from the ETAS download center (type: technical doc-
umentation).

5) This document can be obtained from the ETAS download center (type: specification).

6) The CDF specification is available for download on the web pages of the ASAM Association for
Standardization of Automation and Measuring Systems under www.asam.net.
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14 Contact Information

Technical Support

For details of your local sales office as well as your local
technical support team and product hotlines, take a look at
the ETAS website:

www.etas.com/hotlines

ETAS offers trainings for its products:

www.etas.com/academy

ETAS Headquarters
ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany Internet: www.etas.com
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15 List of Abbreviations

This manual uses the following abbreviations:

AUTOSAR – AUTomotive Open System ARchitecture

ASAM-MCD – Association for Standardisation of Automation andMeas-
uring Systems (Measurement, Calibration and Diagnosis)

CAN – Bus System for Data Communication (Controller Area Network)

CCP –CANCalibration Protocol, standard protocol based on MCD-1a

CDM –Calibration DataManager

DB – Database

DBM – DatabaseManager

ECU – ElectronicControl Unit

EE – Experiment Environment

ETK – Emulator-Tastkopf (emulator test probe)

EXP – Experiment

FIBEX – Field Bus Exchange

HWC – Hardware Configuration

INCA – INtegratedCalibration and Acquisition Systems

MDA –Measure Data Analyzer

MDF –Measurement Data Format

RP – Reference Page

WP –Working Page

WS –Work Space

XCP – eXtendedCalibration Protocol

INCA V7.6 | Tutorial



Figures | 112

Figures

Fig. 2-1: INCA System Overview 10

Fig. 2-2: The Calibration and Measurement Applications 15

Fig. 2-3: Memory emulation 16

Fig. 7-1: Recording process when using a fixed time interval. 61

Fig. 7-2: Relation pre start trigger and post stop trigger times. 62
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