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1 はじめに
本章には、使用目的、対象となるユーザー、安全性や個人情報に関する情報が記載されてい
ます。
本製品を使用する際には、ユーザーの負傷やデバイスの損壊などを避けるため、「ETAS 
Safety Advice - 安全上のご注意」（Help > Safety Advice）、および下記の注意事
項をよくお読みいただき、その指示に従ってください。
製品の不適切な使用や安全に関するメッセージに従わないことにより生じた一切の損害につい
て、ETAS GmbHは責任を負いません。

1.1 本製品に関する注意事項
本製品を安全に使用するには、一般的な注意事項に加え、以下の要件も守ってください。

本製品の準備や操作を行う前に、本製品を使用する環境が所定の条件を満たしてい
ることを確認してください。各条件については、使用するPCやハードウェアのドキュメントを
参照してください。

1.2 製品の正しい使用法
ETAS ASCMOツールファミリは、オフラインデータに基づくモデリングや、モデルベース適合、さらに
は物理値モデルのパラメータの効率的な最適化を目的としています。稼働中のシステムで直接
動作することは意図されていません。
ASCMO-STATICとASCMO-DYNAMICを使用すれば、少量の測定データから複雑なシステ
ムの挙動を正確にモデル化することができます。このモデルは、入力パラメータの分析と最適化に
使用したり、他のシミュレーション環境においてプラントモデルのブラックボックスとして使用すること
もできます。対照的にASCMO-MOCAは、定義された構造を持つ既存の物理値モデルを使用
して、モデル自体のパラメータを調整して最適化します。その結果は「提案」として扱われるもの
で、後続の処理を行う前に検証を行う必要があります。
製品の不適切な使用や安全に関する注意事項に従わないことにより生じた一切の損害につい
て、ETAS GmbHは責任を負いません。詳細は Help > Safety Advice を参照してくださ
い。

1.3 対象ユーザー
この製品は、自動車用ECUの開発および適合の部門において訓練を受けた有資格者を対象
としています。本書の内容をご理解いただくには、計測や、制御ユニットのエンジニアリングに関す
る専門知識が必要です。

1.4 安全に関する注意事項の記述書式
以下の「安全に関する注意事項」は、人身事故や物的損害につながる危険性を警告するもの
です。
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危険 

危険：記載事項を守らないと死亡または重傷のリスクが高い危険性について説明していま
す。

 

 警告  

警告：記載事項を守らないと死亡または重傷のリスクを招く可能性のある危険性について説
明しています。

 

注意 

注意：記載事項を守らないと軽～中程度の負傷のリスクを招く可能性のある危険性につい
て説明しています。

 

ご注意ください！ 
ご注意ください！：記載事項を守らないと物的損害を招く可能性のある危険性について説
明しています。

 

注意喚起 
注意喚起：記載事項を守らないとデータ損失、データ破損、システムの脆弱性といったデジタ
ル資産への損害を招く可能性のある危険性について説明しています。
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1.5 安全に関する注意事項

ご注意ください！ 
誤った実験計画による損害
ASCMO-DYNAMIC ExpeDes における誤ったエンジン設定は、エンジンやテストベンチの損
傷を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエン
ジンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

ASCMO-DYNAMIC ExpeDesについては、6.10  ステップ8：エクスポート（"Export"）
（ページ87）と6.2  ステップ1：一般設定（ページ62）を参照してください。
 

1.6 データ保護
製品に個人データを処理する機能が含まれている場合、データ保護法およびデータプライバシー
法の法的要件は、お客様によって遵守されるものとします。データ管理者として、お客様は通
常、その機能に続く処理を設計します。したがって、保護措置が十分であるかどうかは、お客様に
確認していただく必要があります。

1.7 データと情報のセキュリティ
本製品に関するデータを安全に取り扱うため、データと保管場所、および技術的／組織的な対
策について、以降の項に書かれている内容を参照してください。

1.7.1 データとその保管場所
以下の項では、さまざまな使用例におけるデータとその保管場所について説明します。

1.7.1.1 ライセンス管理
ユーザーネットワーク上のFNPライセンスサーバーで管理されるユーザー固定ライセンスをETASラ
イセンスマネージャで扱うと、ライセンス管理の目的で以下のデータが保存されます：
データ

通信データ：IPアドレス
ユーザーデータ：WindowsユーザーID

保存場所：
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FNPライセンスサーバーログファイル：カスタマネットワーク上
FNEのPC固定ライセンスとして提供されたホストベースライセンスをETASライセンスマネージャで
扱うと、ライセンス管理の目的で以下のデータが保存されます：
データ

アクティベーションデータ：アクティベーションID
 l ライセンスのアクティベーションの目的でのみ使用され、ライセンス使用時に継続的に

使用されることはありません。
保存場所

FNEトラステッドストレージ
C:\ProgramData\ETAS\FlexNet\fne\license\ts

1.7.2 技術的／組織的な対策
お客様のIT部門による適切な技術的／組織的対策（古典的な盗難防止策やハードウェアお
よびソフトウェアへのアクセス保護など）を講じていただくことをお勧めします。
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2 ETAS ASCMOの概要
ASCMO（Advanced Simulation for Calibration, Modeling and Optimization）
は、「実験計画法」（DoE： Design of Experiment）と呼ばれる手法により得られる測定
データに基づいて、未知のシステムの入出力挙動をモデリングするためのツールです。
このような「データベースモデリング」が有効な手段として必要となるのは、システムを物理式で正
確に定義できない場合です。この手法では質の高いモデルを作り上げることができるので、たとえ
ば、内燃機関の大域的挙動といった複雑な関係もマッピングできます。
モデリングが終わると、ETAS ASCMOはシステムの挙動を「可視化」し、モデルを使用して「適
合」／「最適化」を行うための各種選択肢を提示します。ここで適合作業を行い、「内燃機関」
システムのモデリングと最適化を実現します。
ここで使用されるモデリングと最適化の手法は、入力変数によって出力変数の値が連続的に変
化するようなシステムにも適用できます。

2.1 応用分野
ETAS ASCMOは以下のような分野に応用できます。

ECUの適合
エンジンパラメータの最適化： エミッション、O2 センサヒーターなど
動的ファンクションの最適化： ドライバビリティ、過給圧など
ECUモデルのパラメータ設定（シリンダ充填、トルク、...）

適合分野でETAS ASCMOを使用することには以下のような利点があります。
測定と解析の工程全体の効率が大幅に向上します。
複雑性を適切に扱うことができます。
データの品質が向上します。
モデルの再利用が可能になります。

システムやファンクションの研究開発
実験エンジンの適合と評価を迅速に行えます。
新規ファンクション（コントローラストラテジなど）のテストや開発に実エンジンのモデルを
使用できます。
未知のシステムの解析と最適化が可能です。
 l ハイブリッド車（バッテリサイズ、排気量など）
 l スタータジェネレータシステム： ジェネレータ電流や軸受温度などのモデリング
 l 噴射システムの開発（形状の最適化）
「メタモデリング」が時間依存の物理シミュレーションを加速します。

研究開発分野における主な利点は、システム理解が迅速化され向上することと、さまざまな方
法でインパクト解析を行えることが挙げられます。
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2.2 基本説明
ETAS ASCMO-DYNAMICを用いることにより、複雑なシステムの動的／過渡的挙動を捉え
るデータベースモデルを作成することができます。ASCMO-DYNAMICは、システム挙動の可視
化と解析のための幅広い機能とオプションを提供します。さらに、最適化のためのASCMO-
MOCAへのエクスポートが可能で、DoE手法（実験計画）に基づいた実験計画の作成をサ
ポートします。
ASCMO-DYNAMICは機械学習分野のAI手法を用いているため、基礎となるアルゴリズムの
詳細な知識を必要とすることなく、複雑な関係を正確にモデル化することができます。この柔軟
性により、経験の浅いユーザーでもパラメータ不要の自動モデル作成が行え、経験を積んだ専門
家であれば、豊富な設定オプションの恩恵を受けることができます。
ASCMO-DYNAMICの一般的な用途は、内燃機関における過渡プロセスのモデリングです。
典型例としては、排出ガスと燃料消費を純粋に定常的に考慮するだけでは不十分である実路
走行排気（RDE：Real Driving Emissions）があげられます。ピークなどの動的効果は、
結果全体に大きな影響を与える可能性があります。ASCMO-DYNAMICで燃料消費量や汚
染物質排出量のような関連変数をモデリングする際には、過去の値や変化率が考慮され、動
的な運転操作が関連出力変数に及ぼす影響を詳細かつ時間分解的に分析することができま
す。
ASCMO-DYNAMICで使用される手法の対象は内燃エンジンに限定されないため、電動モビ
リティ（充電戦略など）のような分野にも応用できます。

2.3 実験計画法（DOE：Design of Experiment）
「実験計画法」は、未知のシステムのデータベースモデリングを行うための手法です。

図2-1: 実験計画の立案からモデルベースの最適化まで

そのプロセスは、最小限の測定労力でモデルトレーニング用のデータを得るための実験計画から
始まります。このデータセットを使ってモデルのトレーニングが行われます。
モデルは数学的近似法を基礎とし、測定対象システムの挙動を再現することができます。
モデリングの目的は、システムの挙動を評価して最適化することです。たとえば、内燃エンジンの
最適な出力変数（最大性能、最小の消費や排出量）を得られる入力変数を決定することな
どです。

2.4 モデルベース適合
昨今のECUの適合作業は、さまざまな要因により複雑化の一途をたどり、コストも増大していま
す。
主な要因としては以下のようなものが挙げられます。

ASCMO-DYNAMIC V5.16 | ユーザーガイド



2 ETAS ASCMOの概要 | 12

派生車種の多様性
テスト対象（エンジン、車両）の可用性の低下
燃費、排出物、診断に関する要件の厳格化

このように増大する複雑化により、「古典的な」適合手法では効果的な管理が行えなくなってき
ています。定型的な作業を自動化するとしても、以下のようなステップを反復的に行わなければ
なりません：

ECUパラメータの測定と変更
実験車両／エンジンのレスポンス測定
測定値の解析
段階的な最適化

この手続きをすべて実行することにより、1つの最適なデータセットが得られるのです。
ASCMO-STATICまたは ASCMO-DYNAMICでのモデルベース適合では、実験計画の立案
後に行う実システム上での計測作業は、1回だけですみます。それ以外はすべてモデル上で行わ
れます：

最適化目標を指定した後：1回の最適化実行により最適なパラメータセットが得られま
す。
マップを変更し、その結果得られる挙動を予測することができます。
適合対象の仕様に応じた最適な結果を達成できます。 
 l 小型車の場合は燃費、スポーツカーの場合はトルク
 l スポーティな運転挙動（トルクを即座に得られる）vs. 快適性

この場合、n回の反復により、最適化されたn個のデータセットが算出されます。

2.5 外生入力を伴う非線形自己回帰（NARX）
データ駆動型モデリングアルゴリズム（ASCMO-DYNAMICのASCモデリングの部分など）によ
る動的影響は、高次モデル構造を使用することにより考慮できます。離散時間の場合は、図2-
2に示すように、過去の入力値と出力値のフィードバックによりシステム入力空間が所定の計画
対象期間まで拡大されます。文献ではこれを、「外生入力を伴う非線形自己回帰」
（NARX:Nonlinear autoregression with exogenous inputs）と呼んでいます。以降
の説明ではフィードバック値を「フィーチャー」（features）と呼びます。
このアプローチにより、動的同定問題は以下の式のような準定常的関係に変換されます。
y(k)=f(x_1 (k),x_1 (k-1),…,x_2 (k),x_2 (k-1),…,y(k-1) ,…)

式中のkは離散時間ステップを示します。
連続的に測定されるシステム入力とシステム出力のデータセットに基づいて、ASC モデリングアル
ゴリズム、あるいは他のすべてのデータ駆動型回帰を、関数関係f( ) のモデリングに適用できま
す。

1段先行予測と多段先行予測の違い
モデルトレーニング実施後のモデル予測のシナリオは、以下の2 通りに分かれます（図2-2を参
照してください）。
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1段先行予測（One-step ahead prediction）
1段先行予測の場合は、過去のシステム出力はセンサなどから実測により得られる既知
の値です。モデルが予測しなければならないのはすぐ次の時間ステップだけです。
多段先行予測（Multi-step ahead prediction）
過去のシステム出力値の代わりにモデルの予測が使用されます。これはオフラインシミュ
レーションに相当する標準的な使用事例であり、ユーザーは所定のさまざまな入力に対
するモデルの応答を要求します。
多段先行予測によって得られるモデルは、予測誤差の累積により、1段先行予測による
モデルよりも品質が低くなるのが一般的です。

図2-2: 外生入力を伴う非線形自己回帰（NARX）のモデル構造 － 1 段先行予測
（左）と多段先行予測（右）

5.5.2  1段先行予測／多段先行予測 （ページ43）も参照してください。

2.6 再帰型ニューラルネットワーク（RNN）
ASCMO-DYNAMICでは、過渡的モデリングに「RNN」（Recurrent Neural Networks：
再帰型ニューラルネットワーク）を利用することができます。
このモデルタイプは、オープンソースの機械学習プラットフォームTensorflowを基盤としています。
RNNは、1つの隠れ層を持つネットワーク（ASCMO-MOCAのサンプルプロジェクトにも含まれて
います）といった単純なフィードフォワードネットワークのような従来のニューラルネットワークとは一
線を画しています。従来の「パーセプトロン」と呼ばれるものとは異なり、RNNセルは、トレーニング
可能な重みとバイアスに加え「状態」を保持して再利用します。この「状態」は、RNNが1つの入
力を処理する際に更新され、次の入力を処理する際に利用することができます。つまり、過去の
入力評価の結果が後の入力評価に影響することになるので、そのセルは「記憶を持つ」と見なさ
れます。そのため、RNNは一連のデータからモデルを構築する際に用いる候補として非常に興味
深いものであると言えます。
RNNについての詳細はオンラインヘルプに記載されています。F1を押してオンラインヘルプを開
き、ASCMO-DYNAMIC > ASCMO-DYNAMICの操作 > モデルトレーニング > 
RNNによるモデリング を開いてください。
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2.7 より詳しい情報について
このユーザーガイドに加え、特にユーザーインターフェースを操作する際にはオンラインヘルプのご使
用をお勧めします。Help > Online Help でアクセスでき、また F1 を押下して現在開いてい
るウィンドウに応じたコンテキストヘルプを開くことができます。
Pコードバージョンの機能についてのヘルプにアクセスするには、Help > Interface Help を使
用します。
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3 インストール
インストールを行う前に、お使いのPCがシステム要件を満たしていることを確認してください（シス
テム要件はMOCA ASCMOを参照）。必要なユーザー権限とネットワーク接続があることも確
認してください。
製品をオフラインで使用するには、ETASライセンスマネージャ（LiMa メインウィンドウ > ライセ
ンス > 選択されたライセンスの借用／全ライセンスの借用）でライセンスを借用する必要があ
ります。詳細はLicensingを参照してください。

3.1 システム要件
システムが以下の最小要件を満たしている必要があります：

必要なハードウェア 1.0 GHz PC
4 GB RAM
解像度1024 x 768以上、32 MB RAM以上のグラフィック
ス

必要なオペレーティングシステ
ム

Windows® 10、Windows® 11

必要なディスクの空き容量 4 GB（アプリケーションデータを含まない）

推奨されるシステム要件は以下のとおりです：

推奨ハードウェア 4.0 GHz Quad-Core PC、またはそれと同等のもの
32 GB RAM
解像度1680 x 1050、128 MB RAMのグラフィックス

推奨オペレーティングシステム Windows® 10、Windows® 11

推奨されるディスクの空き容量 4 GB以上

3.2 ソフトウェア要件
ETAS ASCMOにはMATLAB® Compiler Runtime 2022bが必要で、ない場合は自動
的にインストールされます。また、Windows® 10/11に含まれる.Net Framework V4.6も
必要です。
ETAS ASCMOの基本製品およびアドオンのインストール時に必要なソフトウェア要件はありませ
ん。足りないソフトウェアコンポーネントは、インストール実行中にすべてインストールされます。
ETAS ASCMOアドオンのSoftware Developer Kit (SDK)を使用するには、MATLAB®

バージョンR2021b ～ R2023bと、MATLAB®のOptimization ToolboxとStatistics 
Toolboxが必要です。
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3.3 インストール
ETAS ASCMOのインストール

 1. ASCMOインストールファイルが格納されているディレクトリを開きます。
 2. Setup_ETAS-ASCMO_Vx_x_20xxx.exeをダブルクリックします。

License Agreement ウィンドウが開きます。

 3. ライセンス許諾書の内容をよく読んで、I accept the agreement オプションを選択
します。

 4. Next をクリックします。
すでにASCMOがインストールされている場合は、既存のインストールパス（インストール
先とスタートメニューフォルダ）が使用され、ステップ5～8はスキップされます。

 5. Set Destination Location ウィンドウで、提示されるデフォルトフォルダを承諾する
か、または Browse をクリックして新しいディレクトリを選択します。

 6. Next をクリックします。
 7. Select Start Menu Folder ウィンドウで、提示されるデフォルトフォルダを承諾、また

は Browse をクリックして新しいフォルダを選択します。
 8. Next をクリックします。
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 i. デスクトップアイコンを作成するには Create a desktop icon チェックボックスをオ
ンにします。

 ii. MATLAB® Compiler Runtimeを強制的にインストールするか、または、まだイン
ストールされていない場合にのみインストールするかを選択します。

 iii. 必要に応じて Install Prerequisites をオンにします。
 9. Next をクリックします。

 10. Ready to Install ウィンドウで、Install をクリックしてインストールを開始します。
または

設定内容を変更するには Back をクリックします。
インストールが開始され、進捗インジケータにインストールの処理状況が表示されます。イ
ンストール処理がすべて終了すると、Completing the ETAS ASCMO Setup 
Wizard ウィンドウが開きます。

 11. Finish をクリックします。
インストールが完了します。ASCMOが起動できる状態になります。

3.4 ファイルとディレクトリ
プログラムに関連するすべてのファイルは、インストール時に指定された <installation> ディ
レクトリとそのサブディレクトリに保存されています。
<installation> のデフォルトはC:\Program Files\ETAS\ASCMO x.xです。

スタートメニュー
インストールが正常に終了すると、インストーラの Select Start Menu Folder ウィンドウで
設定したスタートメニューのフォルダに、以下のエントリが追加されます。
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ASCMO Desk V5.16
ASCMO-DESKウィンドウが起動し、ここからETAS ASCMOの各コンポーネントを起動
することができます。
ASCMO Dynamic V5.16
ASCMO-DYNAMICを起動します。
ASCMO ExpeDes Dynamic V5.16
ASCMO-DYNAMIC ExpeDesを起動します。
ASCMO ExpeDes V5.16
ASCMO-STATIC ExpeDesを起動します。
ASCMO MOCA Runtime V5.16
ASCMO-MOCA Runtime（機能制限付き）を起動します。
ASCMO MOCA V5.16
ASCMO-MOCAを起動します。
ASCMO Static V5.16
ASCMO-STATICを起動します。
Manuals and Tutorials
ASCMOドキュメントフォルダ（<installation>\Manuals）が開きます。ここには
以下の情報や文書が保存されています。
 l ASCMOInterfaceDoc - インターフェースに関する文書が保存されたフォルダ
 l Examples - 各種サンプルデータ（ASCMOプロジェクト、

MF4／DCM／XLS／FMUファイル、テンプレート、プラグインなど）が含まれるフォル
ダへのショートカット

 l HTMLフォルダ - インストール済みコンポーネント用のオンラインヘルプファイル
（<F1> キーで開きます）

 l ASCMO-DYNAMIC_V5.16_User_Guide_*.pdf - ユーザーガイド  - 
ASCMO-DYNAMICの基本機能の説明やチュートリアルを含む

 l ASCMO-STATIC_V5.16_User-Guide_*.pdf - ユーザーガイドASCMO-
STATICの基本機能の説明やチュートリアルを含む

 l ASCMO-MOCA_V5.16_User-Guide_*.pdf - ユーザーガイドASCMO-
MOCAの基本機能の説明やチュートリアルを含む

Pコードファイル
MATLAB®/Simulink®用のPコードファイルは、<installation>\pCode\ascmo に
保存されています。
詳細はPコードバージョン（下記）を参照してください。

3.5 Pコードバージョン
PコードバージョンのETAS ASCMOは、MATLAB®から直接起動することができます。
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前提条件
Pコードバージョンを使用するには、MATLAB® R2021b ～ R2023bがインストールされている
必要があります。さらに、以下のMATLAB®ツールボックスも必要です。

Optimization Toolbox™
Statistics and Machine Learning Toolbox ™

ETAS ASCMOの実行
MATLAB®で、ディレクトリ <installation>\pCode\ascmo に切り替えます。続いてコ
マンドウィンドウに以下の表のコマンドを入力します。

コマンド 機能

AscmoDesk ASCMO-DESKを起動します。

ascmo static ASCMO-STATICを起動します。

ascmo expedes ASCMO-STATIC ExpeDesを起動します。

ascmo dynamic ASCMO-DYNAMICを起動します。

ascmo 

expedesdynamic
ASCMO-DYNAMIC ExpeDesを起動します。

ascmo moca ASCMO-MOCAを起動します。

ascmo mocaruntime ASCMO-MOCA Runtimeを起動します。

ascmo 

cyclegenerator
ASCMO Cycle Generator（スタンドアロン走行サイクルジェネ
レータ）を起動します。

ascmo essentials ASCMO Essentialsを起動します。

ETAS ASCMOツール内で実行される全ステップは、コマンドを使用して自動化することができま
す。コマンドについての説明を参照するには、メインメニューから >Interface Help を選択して
ください。

3.6 アンインストール

注記 

各コンポーネントを個別にアンインストールすることはできません。この処理によって すべての 
ETAS ASCMOコンポーネントがアンインストールされます。

ETAS ASCMOのアンインストール
 1. ASCMOインストールファイルが格納されているディレクトリを開きます。

アンインストールを開始します。
確認のメッセージが開きます。

 2. unins000.exe をダブルクリックします。
確認のメッセージが開きます。

ASCMO-DYNAMIC V5.16 | ユーザーガイド



3 インストール | 20

 3. ETAS ASCMOとそのコンポーネントを完全に削除するには、Yes をクリックします。
アンインストールが開始されます。アンインストールが完了すると、メッセージウィンドウが開
きます。

 4. OK をクリックしてアンインストールを完了します。
ETAS ASCMOとそのすべてのコンポーネントが正しくアンインストールされます。
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4 ASCMO-DYNAMICの操作

4.1 ASCMO-DYNAMICのユーザーインターフェース
本項では、ASCMO-DYNAMICのユーザーインターフェースについて概説します。
メインメニューの機能と、それに関連する各種ダイアログウィンドウについての詳細な説明は、コン
テキスト依存のオンラインヘルプ（<F1>、または Help > Online Help）に記載されていま
す。

4.2 ASCMO-DYNAMICユーザーインターフェースのエレメント

ASCMO-DYNAMICメインウィンドウは以下の領域で構成されています。
➀ メインメニュー
➁ ツールバー
➂ 入力

ツールバーのすぐ下に、"Dataset" コンボボックスと  ボタンがあります。

➃ 出力
➄ ログウィンドウ
ステータスバー（最下行）: 現在のステータス情報

"Data Set" ドロップダウン
すべてのトレーニングデータとテストデータが表示されます。ここで選択したデータセットが Inputs 
領域と Outputs 領域に表示されます。

 ボタンをクリックすると、"Manage Datasets" ウィンドウが開きます。詳しくはManaging 
Datasetsを参照してください。
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"Inputs" 領域
入力 x1,..., xn についての情報が、ASCMO-DYNAMICメインウィンドウ上部のタイムベースプ
ロットの左側に表示されます。

注記 

入力に関する各種情報を非表示にするには、View > Show * を選択します。

A 入力の名前と単位
ボタンをクリックして名前と単位を変更します。
B 入力の現在値
 l Value：プロット上のカーソル位置の入力値
 l Max／Mean／Min：入力の最大値、平均値、最小値
 l Sum：すべての入力値を合計した値

別の時間における値を表示するには、プロット上のカーソルを移動します。

"Outputs" 領域
モデリングされた出力は、ASCMO-DYNAMICメインウィンドウ下部のタイムベースプロットの左
側に表示されます。

注記 

出力に関する各種情報を非表示にするには、View > Show * を選択します。
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A 出力名
ボタンをクリックすると "Model Configurations" ウィンドウが開きます。
ドロップダウンで、ワーキング（青色）とリファレンス（緑色）のモデルタイプを選択できま
す。出力のモデリングメソッドとモデルタイプは、出力のコンフィギュレーション（Model > 
Configurations）で設定できます。

複数のモデルのトレーニングを行って、容易に出力を比較することができます。1つの出力
について複数のコンフィギュレーションを定義することが可能です（Model > 
Configurations）。コンフィギュレーションでは、モデリングメソッドとモデルタイプが定義
できます。これにより、1つの出力に対して、異なるモデリングメソッドを簡単に適用すること
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ができます。さらに、コンフィギュレーションを再利用して、ワーキング／リファレンスモデルの
別の出力に適用することもできます。これらのコンセプトと設定については、オンラインヘル
プに詳しく説明されています。
B モデルトレーニング
選択されているコンフィギュレーションを使用してモデルトレーニングを行います。ワーキング
モデル、リファレンスモデル、またはその両方を選択できます。
C 出力の現在値
 l RMSE: 2乗平均平方根誤差を表示します。
 l R2: モデルの不確かさ
 l Sigma：プロット上で指定された時刻におけるモデルの不確かさ
 l Value：プロット上で指定された時刻における出力値
 l Max／Mean／Min：出力の最大値、平均値、最小値
 l Sum：すべての出力値を合計した値

注記 

ドロップダウンで、モデルをリファレンスモデルとして定義し、選択していた場合は、リファレ
ンスモデルの値が表示されます。

D ツールチップ
出力の実測値、予測値と実測値の差、予測値と参照値の差が、ツールチップに表示さ
れます。

別の時間とモデルシグマを表示するには、プロット上のカーソルを移動します。

ログウィンドウ
この領域には、ヒント、ステータスメッセージ、処理（最適化ランなど）の結果などが表示されま
す。
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5 チュートリアル：ASCMO-DYNAMICの操作
ASCMO-DYNAMIC（動的システム同定用ETAS ASCMOツールボックス）の基本的機能
を紹介します。チュートリアルの構成は以下のとおりです。

5.1  測定対象エンジンの入力と出力（下記）
5.2  データのインポート（次ページ）
5.3  データの分析 （ページ29）
5.4  モデルトレーニング（ページ35）
5.5  モデル予測 （ページ42）
5.6  モデル検証（ページ44）
5.7  モデルのエクスポート （ページ48）

5.1 測定対象エンジンの入力と出力
測定対象の例（ディーゼルエンジン）の入力と出力は図5-1:  下記と表に説明されています。

図5-1: 測定対象となるディーゼルエンジン

 Name 意味

入力
 

PedalPosition スロットルペダル位置 [%]

EngineSpeed エンジン回転数 [rpm]

出力
 

TurboChargerShaftSpeed ターボチャージャー回転数 [rpm]

mdot_exhaust 排ガスの質量流量 [kg/h]

表5-1: 測定対象となるディーゼルエンジンの入力と出力

モデリング用データ
測定済みのデータセットは18000の測定ポイントからなる連続的データストリームで、そのうち
4000ポイントがモデリングに使用され、残りの14000ポイントがテストデータセットになります。サ
ンプリング間隔は0.1秒です。
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5.2 データのインポート
本項では、トレーニングデータのインポートについて説明します。
ASCMO-DYNAMICの起動

 1. WindowsスタートメニューのETAS ASCMO V5.16プログラムグループから、
ASCMO Desk V5.16 を選択します。
ASCMO-DESK ウィンドウが開きます。

図5-2: ASCMO-DESK ウィンドウ

 2. ASCMO-DESK ウィンドウで、Transient Modeling タイルをクリックします。
ASCMO-DYNAMICが開きます。

図5-3: ASCMO-DYNAMICスタートウィンドウ

トレーニングデータをロードしてインポートする
新しくプロジェクトを作成するには、まずモデルトレーニングに必要なトレーニングデータをロードする
必要があります。
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 1. ASCMO-DYNAMICスタートウィンドウで、左側のメニューパネル内の New をクリックし
ます。

 2.  をクリックします。

ASCMO Data Import ウィンドウとオープンファイルダイアログが開きます。
 3. オープンファイルダイアログで、トレーニングデータが含まれるファイルを選択します。
 4. 開く をクリックします。
 5. *.xls ファイルを選択した場合は、以下を行います。

 i. ファイルに複数のワークシートが含まれている場合は、必要なワークシート
（Training Data）を選択します。

 ii. OK をクリックします。
Time Vector / Sample Time ウィンドウが開きます。

 iii. Sample Time フィールドに、トレーニングデータのサンプルレート（秒単位）を入
力します。
トレーニングデータテーブルには時間列がないため、ここでは Time Vector フィール
ドは無視できます。

 iv. OK をクリックします。
データが読み取られます。

注記 

ファイルのサイズによっては読み取り処理に時間がかかる場合があります。

 6. 入力として PedalPosition と EngineSpeed を選択し、出力として mdot_
exhaust と TurboChargerShaftSpeed を選択します。
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注記 

ASCMO-STATICの場合とは異なり、ASCMO-DYNAMICでは動作ポイントは考
慮されません、使用できるのは Normal だけです。

インポートデータインターフェースでは、ASCMO-STATICと同様に、データの妥当性を視
覚的に確認したり（Plot Selected）、選択されている入力と出力の割り当ての設定
を保存／ロードしたり（File > Save/Load Channel Config (*.ini)を参照）
することができます。

 7. ASCMO Data Import ウィンドウで、Import をクリックします。
測定データがインポートされ、プロジェクトが作成されます。データのインポートが終わると、
ウィンドウに入力（上）と出力（下）の時系列グラフが表示されます。

コンフィギュレーションを保存する
 1. File > Export Data > Channel Config... を選択します。
 2. ファイル選択ダイアログボックスが開くので、現在のコンフィギュレーションを保存するファイル

のパスと名前を入力し、保存 をクリックします。
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コンフィギュレーションをロードする
 1. すでに保存されているコンフィギュレーションをロードするには、File > Import Data > 

Training / Validation / Test を選択します。
 2. 新しいウィンドウで File > Load Channel Config (*.ini, *.lab) を選択しま

す。

5.3 データの分析 
ASCMO-DYNAMICの実際のモデリング（5.4  モデルトレーニング（ページ35）を参照）はシ
ンプルで、データの前処理は必要なく、初めてのユーザーでも実行できますが、ここで、ロードされ
たデータセットの分析を行っておくことをお勧めします。
Data メニューにはモデル品質の向上に役立つツールが用意されていて、ロードされたデータセット
の確認や変更を行うことができます。

5.3.1 トレーニングデータテーブル
Data > Table > Training Data を選択すると、データが時系列に一覧表示されます。

5.3.2 散布図 
散布図ウィンドウ（Data > Scatter Plot > Training Data）に表示される各プロットを
見ると、入力と出力について発生し得る範囲内におけるトレーニングデータのカバー率がわかりま
す。Data Set vs. Time プロットで任意のブロックをマークすると、そのブロック内のポイントの
時間ステップにおける入力値と出力値が他のプロット内で示されます。
散布図は、後のモデル検証（5.6  モデル検証（ページ44）を参照）において、データが入力
データの範囲内に収まっているかどうかをチェックする際に役立ちます。ASCMO-DYNAMICは
データ駆動型のモデリングアルゴリズムを使用し、カバーされない領域への正しい外挿は保証され
ないため、このチェックは非常に重要です。
各プロットの表示設定は、散布図ウィンドウの Configuration > X-Axis / Y-Axes で変
更できます。
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図5-4: ASCMO-DYNAMIC散布図ウィンドウ（デフォルト設定）

5.3.3 リサンプリング 
測定データのサンプリング周期 Ts は、短すぎる（つまりサンプリング周波数が高すぎる）場合が
あります。適切なサンプリング周期はおよそ Ts ≤ T/10（T はシステムの主要時定数）です。
そのような場合は、データセットをリサンプリング（ダウンサンプリング）することによってトレーニング
時間を短縮でき、後のモデリングにも役立ちます。リサンプリング処理は、Data > 
Resampling で開始します。
リサンプリング係数 n を指定するだけで、元の時系列のデータをn番目ごとに抽出して、新しい時
系列のデータセットを生成することができます。
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Sample Time を設定すると、2つのサンプル間の絶対的な時間差（秒）を定義することが
できます。Reduction Factor は、元のサンプリングレートに対する削減係数で、たとえばこれ
を2に設定すると、2つのサンプル間の絶対的な時間差は、元のデータの2倍になります。どちらの
設定を行っても元データがリサンプリングされ、必要に応じて線形補間が行われます。
データサイズに関する情報フィールドには、現在のサンプリングレートと元のサンプリングレートによる
サンプル数が表示されます。
トレーニングデータの元のサンプル数と、現在のオプション設定に応じたリサンプリング後のサンプル
数が自動計算され、Resampling ウィンドウに表示されます。

注記 

このチュートリアルのディーゼルエンジンの例では、リサンプリングは必要ありません。

5.3.4 ノイズフィルタリング 
信号の乱れを除去するため、移動平均フィルタを使用してデータセットを修正することができ
（Data > Noise Filtering）、これによって以下のように新しい信号が生成されます：

n = フィルタウィンドウのサイズ
ウィンドウサイズ n は時間ステップ内で与えられるため、現在のサンプルタイムに依存します。
サンプルタイムが0.1sでウィンドウサイズが10の場合、移動平均ウィンドウの幅は1sになります。
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測定ノイズは、信号の振幅スペクトルなどにより識別できます（5.3.6  振幅スペクトル（次ペー
ジ）を参照）。

注記 

このチュートリアルのディーゼルエンジンの例では、ノイズフィルタリングは必要ありません。

5.3.5 入力の相互相関 
すべての入力に相関関係がまったくないというのが理想的です。これについては相互相関分析
（Data > Cross Correlation Inputs）で調べることができます。

注記 

相互相関分析は、"Advanced Settings" オプションがオンになっている場合にのみ実行で
きます。

ディーゼルエンジンを例に、望ましい挙動を下図に示します。左上と右下の CCF(xi,xi) のプロッ
トは各入力のそれ自体との相互相関性を示すもので、実際にはタイムラグ（時間差）に応じた
信号の自己相関を示しています。
理想的なケースでは、タイムラグが0の時に1.0という（完全）相関になり、指数関数的に減少
する関数が得られます。CCF/ACFの減少が緩やかであればあるほど、時間経過に対する信号
の変化が小さいことになります。
さらに注目すべきものは、入力チャンネル間のCCFを示す右上のプロットです。このディーゼルエン
ジンの例のように無相関であることが望ましい状態です。相互相関内にピークがあれば、それは
入力チャンネル間に相関関係があることを示し、相互相関が1.0であれば、それらは冗長信号と
いうことになります。
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5.3.6 振幅スペクトル
Data > Spectrum of Channels を選択すると、入力と出力の振幅スペクトルを表示す
ることができます。やや狭いピークが見られる場合は、当該周波数程度のノイズが存在しているこ
とを示しています。
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5.3.7 位相プロットとACF／IACF
Data > Phase Plot and IACF Outputs を選択すると、同定タスクの時間依存性を明
らかにできます。プロットは出力ごとに個別のウィンドウに表示されます。

位相プロット（"Phase Plot"） 
Output (k-t) に対するOutput (k) の散布図：位相/ラグ t の値はウィンドウ左下部で
調整できます（標準的な値は1です）。
図5-5:  下記上部のプロットは、あるステップからtステップ後までの時間経過に伴う出力値の変
化を示しています。多くの点がほぼ対角線上にあってあまり分散していなければ、output(k) 
と、位相シフトされた output(k-t) との間に、強い依存関係があることになります。一般的
に、このようになるのは t = 1 の場合です。t を1ずつ大きくしていくと、点の分布はだいたい等し
くなります。このようにして出力の時間依存性を推測することができます。

図5-5: 1 つの出力についての位相プロットとIACFプロット

Autocorrelation Function (ACF)/Inverse Autocorrelation 
Function (IACF) 
ACF（自動相関関数）とIACF（逆自動相関関数）による分析では、外生入力変数を伴
わない線形時系列が想定されます。これはディーゼルエンジンの例のような非線形システムの同
定には当てはまりませんが、これに基づいて、存在する時間依存性について最初の仮説を立てる
ことはできます。
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期待されるACFの形状は、指数関数的に減少する曲線か、または正弦曲線です。数タイムラグ
後に突然減少している場合は、その時系列の中に自己回帰部分がない（つまり時間依存性
がない）ことがわかります。
図5-5:  前ページ下部のIACFプロットは数ステップ後に減衰するべきもので、それにより自己回
帰部分の次数が決まります。破線はカットオフ目標を表し、これは下の式で求められる95% の
信頼区間です。

IACFの挙動が指数関数的または正弦関数的な場合は、自己回帰性はありません。ディーゼ
ルエンジンの例では、IACFは 3 タイムラグの信号シフト後に減衰します。これは、この次に行うモ
デルトレーニングのタイムラグ期間として考慮されます。

5.4 モデルトレーニング
モデルトレーニングは、Model > Configurations（Model Configurations ウィンドウ
（次ページ）参照）または Model >TrainModels（Model Configuration All 
Outputs ウィンドウ（ページ37）参照）から開始できます。
Model > Configurations でトレーニングを開始すると、出力ごとにモデルプロパティを設定
することができます。設定については以下の内容について説明します。

モデリングメソッド（このチュートリアルではNARX Structure を使用）
メソッドパラメータ
NARX Structure メソッドには以下のパラメータがあります。
 l モデリングアルゴリズム（モデルのグローバルコンフィギュレーションを設定してトレーニン

グを開始する（ページ37）を参照）
 l フィードバック（NARX）構造（「フィードバック構造」を参照）
 l 次元削減（「次元削減」を参照）

モデルの個々のプロパティを設定してトレーニングを開始する
 1. Model > Configurations を選択します。

Model Configurations ウィンドウが開きます。各出力のプロパティがそれぞれのタブ
に表示されます。
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図5-6: Model Configurations ウィンドウ

 2. Modeling Method ドロップダウンリストで NARX Structure を選択します。
 3. Model 領域で、以下を行います。

 i. ドロップダウンリストからモデルタイプを選択します。5.4.1  モデリングメソッドとアルゴリズ
ム（ページ38）を参照してください。
<output> - Parameters ウィンドウが開きます。ウィンドウの内容はモデルタイプ
に応じて異なります。

 ii. <output> - Parameters ウィンドウで、モデルパラメータを設定します。
ウィンドウの説明は、"NARX Model Types"（オンラインヘルプ）を参照してくださ
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い。
 iii. OK をクリックして <output> - Parameters ウィンドウを閉じます。

<output> - Parameters ウィンドウは、Edit ボタンでも開くことができます。
 4. Feedback Structure 領域で、入力と出力の最小／最大のタイムラグを設定しま

す。
5.4.2  フィードバック（NARX）構造（ページ39）を参照してください。

 5. Dimensionality Reduction 領域で、None を選択します。
このディーゼルエンジンサンプルでは None で十分です。詳しくは5.4.3  次元削減 
（ページ39）を参照してください。

 6. すべての出力についてモデルパラメータを設定したら、OK または Apply をクリックしてト
レーニングを開始します。

モデルのグローバルコンフィギュレーションを設定してトレーニングを開始する
Model > Configuration for All でトレーニングを開始すると、すべての出力についてモデ
ルパラメータを設定することができます。

 1. Model > Configuration for All を選択します。
Model Configuration All Outputs ウィンドウが開きます。

図5-7: Model Configuration All Outputs ウィンドウ

このウィンドウに含まれるエレメントは Model Configurations ウィンドウ（図5-6:  
前ページ）と同じですが、すべての出力が対象となるため、出力ごとのタブがありません。

 2.  モデルの個々のプロパティを設定してトレーニングを開始する（ページ35）に説明されて
いる方法でモデルプロパティを設定します。

注記 

ここでの設定内容は、すべての出力に適用されます。

 3. OK をクリックしてトレーニングを開始します。
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5.4.1 モデリングメソッドとアルゴリズム
デフォルトのモデリングメソッドはNARX Structureで、デフォルトのモデリングアルゴリズムは 
ASCMO Gaussian Process Spectrum（ASC GP-Spectrum）です。標準的なASCア
ルゴリズムの改良により、大量のデータセットを処理できるようになりました。
ASC GP-Spectrum を使用する場合は、基底関数の数 s を設定する必要があります。モデ
ルのトレーニング中に、データセット全体に含まれる情報が s 個の仮想基底ポイントのセットに変
換されます。s が大きいほどモデリング結果が向上しますが、モデリングにかかる時間は長くなりま
す。推奨される s の範囲は 50 < s < 200 です。
基底関数の数（No. Basis Functions）やその他のモデルパラメータは、以下の 
<output> - Parameters ウィンドウで設定します。モデルタイプ ASC GP-Spectrum を
選択すると自動的にウィンドウが開き、Edit ボタンでも同じダイアログボックスを開くことができま
す。

ASCMO Gaussian Process Sparse Constant Sigma（ASC GP-SCS）モデルは、ト
レーニングデータの数が多い場合に推奨されます。
ASCMO Gaussian Process（ASC GP）モデルは、トレーニングデータの数が少ない場合に
推奨されます。
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線形モデルのトレーニングを行うためのモデルタイプ Linear も用意されています。線形モデルの
場合は、<output> - Parameters ウィンドウで編集できるパラメータの数が少なくなりま
す。
Advanced Settings オプション（File > Options）がオンになっていると、ASC GPモデ
ルの Edit ボタンが有効になり、詳細パラメータを設定することができます。

モデリングのメソッドとアルゴリズムについての詳細は、オンラインヘルプ（<F1>）を参照してくだ
さい。

5.4.2 フィードバック（NARX）構造
すべての入力と出力について、NARX構造内で考慮される最大タイムラグの定義です。以下の
説明ではフィードバック値を「フィーチャー（feature）」と呼びます。
最初は、IACF分析の結果（5.3.7  位相プロットとACF／IACF（ページ34）を参照）を使
用することをお勧めします。ディーゼルエンジンの例では、両方の値が3になっています。

5.4.3 次元削減 
フィードバック値（フィーチャー）の数を少なくすると、モデル品質を高め、さらにモデルトレーニング
を高速化することができます。
Model properties ウィンドウ（図5-6:  ページ36）で、次元削減についての以下のオプショ
ンを選択できます。
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None：NARX構造内のすべてのフィーチャーを、設定されている最大タイムラグに応じ
て使用します。ディーゼルエンジンの例の場合は、これで十分です。
Feature Extraction (PCA)：主成分分析（PCA：principle component 
analysis）を使用して、指定されたフィーチャー数までフィードバック構造の次元を削減
します。

注記 

多くの場合、冗長性などの理由から、フィードバック構造のすべてのフィーチャーが必要
なわけではありません。フィーチャー数を少なくすることがモデルトレーニングの高速化に
役立ちます。

Automatic Feature Selection：手動でのフィーチャー選択の代わりに、自動検
索により適切なフィーチャー設定を行うことができます。
Manual：手動でのフィーチャー選択により、Inputs／Output テーブル内のチェック
ボックス（図5-6:  ページ36）でフィーチャーのセットを明示的に選択することができま
す。
このオプションは、Dimensionality Reduction = None によるモデルトレーニング
で十分なモデル品質が得られなかった場合や、システム固有の時間依存性がわかってい
る場合に有用です。

フィーチャーを自動選択する

注記 

複数のシステム出力が存在する場合は、出力ごとにこの処理を行う必要があります。
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 1. Model > NARX Feature Search > Configureを選択します。

 2. 

 3. Model Type ドロップダウンリストで、フィーチャーの自動選択に使用したいモデルタイプ
を選択します。
最良の結果を得るには、実際のモデルトレーニングで使用するものと同じタイプを選択し
てください。

 4. 必要に応じて、Edit Model をクリックして <output> - Parameters ウィンドウ
（5.4  ページ35）を開き、モデルパラメータを編集します。

 5. Search Method フィールドで、使用するメソッドオプションを選択します。
Forward Selection
「前方選択」は、空のフィーチャーセットから始め、モデル品質を最大限高めるフィーチャー
を追加していく処理を繰り返します。収束を速めるための推奨設定です。
Backward Elimination
「後方除去」は、始めはすべてのフィーチャーを使用し、モデルへの影響が最も少ない
フィーチャーを除外していく処理を繰り返します。この利点は、フィーチャー間の相互依存
性が識別される点にあります。
Heuristic Elimination
「ヒューリスティック除去」は、始めはすべてのフィーチャーを使用し、ヒューリスティック入力の
関連性に基づいて、モデルへの影響が最も少ないフィーチャーを除外していく処理を繰り
返します。他のメソッド、特に「後方除去」と比較して、より早くNARX構造を見つけること
ができます。
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Lag-Wise Search
このチェックボックスがオンになっていると、入力がラグワイズで検索されます。これにより
フィーチャー検索が高速化されます。

 6. Stop Criteria [%] フィールドに停止目標値を入力します。
モデル品質がこれ以上向上できない場合（Forward Selection 使用時）、または指
定された停止値よりも悪くなる場合（Backward Elimination 使用時）に、検索が
停止します。

 7. Min Time Lag／Max Time Lag フィールドに、入力と出力の最小／最大のタイ
ムラグを設定します。

 8. Search Features をクリックして自動フィーチャー選択を開始します。検索には時間を
要する場合があります。Automatic Feature Selection <output> ウィンドウ
の右上のプロット内に進捗状況が表示されます。
検索が終了すると、最良の結果がマークされます。

 9. Apply をクリックして結果を適用します。
すべての出力についてフィーチャーを選択したら、Model Properties ウィンドウに戻り、OK ボ
タンでモデルトレーニングを開始します。

5.5 モデル予測 
モデルトレーニング終了後、トレーニングデータセットの出力測定値の上に重ねてモデル予測がプ
ロットされます。モデルの品質は RMSE および R2 という指標により示されます。
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5.5.1 シグマ予測 
ASC Dyn アルゴリズムでは、モデルの不確かさを示すシグマ予測を得ることもできます（View 
> Show Sigma）。
モデルの挙動が弱い（つまりR2の値が小さい）ほど、シグマの値が大きくなります。ディーゼルエン
ジンの例では、モデル品質が非常に優れているため、シグマの値が小さくなっています。

5.5.2 1段先行予測／多段先行予測 
NARX モデルの予測メカニズムを1先行予測または多段先行予測に切り替えることができます
（Model > NARX Model Options > One Step Ahead Prediction / Multi 
Step Ahead Prediction）。
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注記 

多段先行予測は、測定値の代わりに過去のモデル予測をフィードバック（NARX）構造内で
使用するという点が、1段先行予測と大きく異なります（図2-2:  ページ13を参照）。デフォ
ルトでは多段先行予測が選択されていて、これは実際のオフラインシミュレーションに相当し、
モデル予測中にシステム応答を得ることはできません。

5.6 モデル検証
ある1つのデータセットに基づくモデル品質を確認する目的で、第2のデータセット（テストデー
タ）をインポートすることができます。
テストデータをインポートする

 1. File > Import Data > Test を選択します。
ファイル選択ウィンドウが開きます。

 2. <installation>\Example\AscmoDynamic  フォルダにナビゲートし、
Example_Dynamic_Engine.xls というファイルを選択します。

 3. 開く をクリックします。
 4. Select Sheet ウィンドウで、Test Data というシートを選択します。
 5. OK をクリックします。

Time Vector / Sample Time ウィンドウが開きます。
 6. Sample Time フィールドに、トレーニングデータのサンプルレート（秒単位）を入力し

ます（ モデリング用データ（ページ25）を参照）。
テストデータテーブルには時間列がないため、ここでは Time Vector フィールドは無視
できます。

 7. OK をクリックします。
Additional Data to ASCMO project ウィンドウが開きます。
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トレーニングデータとテストデータは同じ測定サイクルのものなので、そのままマッピングでき
ます。

 8. OK をクリックしてテストデータをインポートします。
データセットがロードされると、ASCMO-DYNAMICウィンドウにモデル予測が表示されま
す。

5.6.1 散布図を用いたモデル検証 
Data > Scatter Plot > All Data で散布図を開き、必要な軸を  View > Select 
Axes で選択して、テストデータの分布とその勾配を調べることができます。

外挿が行われないようにするには、ディーゼルエンジンの例のように、テストデータ（上図の黒い
点）がトレーニングデータの範囲内（上図の黄色い点）に収まっている必要があります。

5.6.2 測定データと予測データ 
メニューコマンド Model > Measured * vs. Predicted（* = Training Data / 
Validation Data / Test Data）と Model > All Measured Data vs. 
Predicted により、トレーニングデータまたはテストデータ、あるいはその両方の測定値をモデル
予測に照らしてプロットできます。期待される結果は左下から右上に向かう対角線で、これは予
測と測定結果が完全に一致している状態に相当します。
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5.6.3 交差検証 
検証に使用するテストデータセットがない場合は、トレーニングデータセットで n重の交差検証を
行うことができます。以下のように操作してください。
交差検証

 1. Model > Cross Validation on Training Set を選択します。

 2. Cross Validation ウィンドウで、交差検証に使用したいデータセットの数を指定しま
す。

 3. OK をクリックします。
設定に応じて、データセットが等しい n 個の部分に分割されます。

出力ごとに n 個のプロットが表示されます。各プロットは n-1 個のデータセットに照らして行われ
たモデルトレーニングの結果と、モデリングに使用されないデータセットについての予測を示していま
す。
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5.6.4 CCR検証
「CCR検証」は、残差の相互相関（CCR: cross-correlation of the residuals）を調べ
るものです。

注記 

CCR検証は、Advanced Settings オプションがオンになっている場合にのみ実行できま
す。

Model > CCR Validation > Residuals * Data
* = Training / Test
トレーニングデータまたはテストデータについて、予測残差の自己相関が表示されます。
望ましい挙動は、タイムラグが0の時に相関が1.0になり、指数関数的に減少することで
す。
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Model > CCR Validation > Residuals and Inputs * Data
* = Training / Test
残差と入力の間に期待される相互相関が0で、顕著なピークがまったくないことが期待さ
れます。

5.7 モデルのエクスポート 

注記 

モデルのエクスポート機能はETAS ASCMOのアドオンとして提供されており、専用のライセンス
（"ASCMO_EXPORT"）が必要です。
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本項では、ASCMO-DYNAMICモデルを以下にエクスポートする方法を説明します：

5.7.1 MATLAB®へのエクスポート 
モデルをMATLAB®にエクスポートすると、出力ごとにMファイルが1つずつ生成されます。

モデルをMATLAB®にエクスポートする
 1. File > Export Model > Matlab を選択します。

"Export to Matlab" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。エ

クスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更できま
す。 
テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB を押し
下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクスポート
されるモデル内における各入力の位置は、♯ 列に表示されます。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.2 Pythonスクリプトにエクスポートする
モデルをPythonにエクスポートすると、出力ごとに*.pyファイルが1つずつ、さらにセルの例を含む
ファイルModelEvaluationExample.pyが生成されます。エクスポートのタイプに応じて、
他のファイルも生成されます。
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モデルをPythonスクリプトにエクスポートする
 1. File > Export Model > Python を選択します。

"Export to Python" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。エ

クスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更できま
す。 
テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB を押し
下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクスポート
されるモデル内における各入力の位置は、♯ 列に表示されます。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存され
ます。エクスポートフォルダへのリンクがログウィンドウに表示されま
す。

5.7.3 Simulink®モデルにエクスポートする
 
Simulink®モデルファイル（*.mdlまたは*.sxl）のほか、m-SファンクションとTLCファイルが
出力ごとに生成されます。
Simulink®モデルには特定のバージョンが割り振られます。PCに複数バージョンのSimulink®
がインストールされている場合、ASCMO-DYNAMICはデフォルトにおいて、新旧に関わらず最
後にインストールされたバージョンを使用します。しかし、エクスポート時にはバージョンを指定して
エクスポートすることができます。
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エクスポート先のSimulink®バージョンを指定する
 1. File > Options を選択します。
 2. Simulink Version ドロップダウンリストから、使用したいバージョンを選択します。

Last installed を選択すると、バージョンの新旧に関わらず、PCに最後にインストール
されたバージョンが選択されます。

 3. OK をクリックします。
モデルをSimulink®にエクスポートする

 1. File > Export Model > Simulink Model を選択します。
 2. ターゲットファイル（Target File）を設定します：エクスポートファイルの保存先のパス

と、ファイル名（<file name>_<model name>）を指定します。
 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。

使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。
 4. Export をクリックします。

エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.4 Simulink®スクリプトにエクスポートする
このエクスポート操作には、Simulinkがインストールされている必要はありません。

モデルを Simulink Script にエクスポートすると、Mスクリプトファイル（*.m）とTLCファイルが
出力ごとに生成されます。後にこれを用いてSimulinkモデルを生成することができます。
モデルをSimulink®スクリプトにエクスポートする

 1. File > Export Model > Simulink Script を選択します。
"Export to Simulink Script (*.m) " ウィンドウ
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 2. ターゲットファイル（Target File）を設定します：エクスポートファイルの保存先のパス
と、ファイル名（<file name>_<model name>）を指定します。

 3. モデルタイプ（Model Type）の設定：スクリプト実行時に作成されるエクスポートファ
イルのモデルタイプ（*.mdl または *.slx）を指定します。

 4. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 5. 出力（Outputs）と入力（Inputs）を選択します。必要に応じて入力の順番を変
更でき、"Used Inputs only" オプションも使用できます。

 6. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.5 INCA／MDAへのエクスポート 
INCA／MDAへのエクスポートでは、モデルがINCA／MDA 6.x用の演算シグナルとしてエクス
ポートされます。MDA 8.xの場合は、FMUへのエクスポートを行います。演算シグナルは、Perl 
モジュール（*.pm）としてINCA／MDAの所定のディレクトリに保存されます。
モデルをINCA／MDAにエクスポートする

 1. File > Export Model > INCA/MDA を選択します。
"Export to INCA/MDA" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）を設定します。ファイル名は 
<base name>_<output> となります。

 3. 使用できる場所とINCA／MDAバージョンのリストから、ターゲットフォルダ（Target 
Folder）を選択します。

注記 

INCA／MDAへのエクスポートを行うには、V6.2以降のINCA／MDAが必要です。
それより前のバージョンは選択できません。
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 4. テーブルからエクスポートする出力（Outputs）を選択します。
 5. Export をクリックします。

エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

注記 

エクスポートされたデータをINCAやMDAで使用する方法については、各製品のユーザーガイド
やオンラインヘルプを参照してください。ユーザーガイドはETASウェブサイトのETASダウンロード
センターから入手できます。

5.7.6 Cコードへのエクスポート
モデルをCコードにエクスポートすると、出力ごとに*.cファイルが1つずつ、さらにモデル固有のCファ
イルが生成されます。
モデルをCコードにエクスポートする

 1. File > Export Model > C Code
"Export to C Code" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。エ

クスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更できま
す。 
テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB を押し
下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクスポート
されるモデル内における各入力の位置は、♯ 列に表示されます。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。
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5.7.7 GT-SUITEへのエクスポート 
GT-SUITEへのモデルエクスポートはCコードエクスポート機能の拡張バージョンで、ASCMO-
DYNAMICモデルをGT-SUITEに直接ロードして使用することができます。モデル出力をGT-
SUITEにエクスポートすると、モデル出力ごとにCファイルが1つずつ作成されます。
モデルをGT-SUITEにエクスポートする

 1. File > Export Model > GT-SUITE を選択します。
"Export to GT-SUITE (*.c)" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。エ

クスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更できま
す。 
テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB を押し
下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクスポート
されるモデル内における各入力の位置は、♯ 列に表示されます。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.8 FMIへのエクスポート 
モデルをFMIにエクスポートすると、入力と出力の仕様が記述されたXMLメタディスクリプションとと
もにCファイルとWindows（32／64ビット）用のDLLファイルが、出力ごとに生成されます。出
力の名前がY1であった場合は、predict_Y1.fmuというファイルが生成されます。
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モデルをFMIにエクスポートする
 1. File > Export Model > FMI を選択します。

Export to FMI (*.fmu)ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. モデルとエクスポートするFMIバージョン（FMI Version）を選択します。
 4. 選択されているすべての出力を1つのFMUファイルにエクスポートするには、Separate 

FMUs チェックボックスをオフにします。
 5. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。

使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。
 6. Export をクリックします。

エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.9 Kerasにエクスポートする
再帰型ニューラルネットワーク（RNN：Recurrent Neural Network）および畳み込み
ニューラルネットワーク（CNN：Convolutional Neural Network）に限り、Kerasにエクス
ポートすることができます。

モデルをKerasにエクスポートすると、*.kerasファイルとtransformation.pyファイルが出
力ごとに生成されます。
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モデルをKerasにエクスポートする
 1. File > Export Model > Keras

"Export to Keras" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. カスタム層を含まないモデルが必要な場合は、Use Custom Layers をオフにします。
 4. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。

使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。
 5. Export をクリックします。

エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.10 Embedded AI Coderへのエクスポート
モデルをEmbedded AI Coderにエクスポートすると、出力ごとにJSONファイルが1つずつ生成
されます。
モデルをEmbedded AI Coderにエクスポートする

 1. File メニュー > Export Model > Embedded AI Coder を選択します。
"Export to Embedded AI Coder" ウィンドウ

 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 
Folder）を設定します。ファイル名は <base name>_<output> となります。

 3. エクスポートしたい出力を選択します。
ASCMOは、チェックされた出力ごとに<base_name>_<output>.ascmo.jsonと
いうJSONファイルを1つ作成します。
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 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.11 Bosch AMUにエクスポートする
ASC GP、ASC GP-SCS、ASC Compressedなど、二乗指数カーネルと対数変換あり／な
しのガウスプロセスモデルを持つNARXモデルのみが、AMUでサポートされています。

モデルをBosch AMUにエクスポートする
 1. File > Export Model > Bosch AMU を選択します。

"Bosch AMU Export" ウィンドウ

 2. "Output" ドロップダウンリストから出力を選択して、パフォーマンスチェックと数値チェック
を行いします。
この結果は、Check Model 領域に表示されます。
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 3. Export Name 入力フィールドでファイル名を設定します。
 4. ドロップダウンリストからマイクロコントローラのアーキテクチャ（Architecture）を選択し

ます。
DFA（Bosch Data Flow Architecture）の互換性は、ドロップダウンリストの横に表
示されます。グラデーション書き出しが選択されている場合、DFAはサポートされません。
IFX Hardware Acceleration
JDP Hardware Acceleration
IFX Pure Software Calculation
JDP Pure Software Calculation

 5. Input Settings テーブルで、各入力の最小と最大のバウンディングボックス
（Min.／Max. Bounding Box）と、勾配をエクスポートするかどうか（Export 
Gradient）を設定します。

 6. すべてのバウンディングボックスの値をリセットするには、  Reset Bounds をクリックしま
す。

 7. エクスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更でき
ます。テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB 
を押し下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクス
ポートされるモデル内における各入力の位置は、Order 列に表示されます。

 8.  Export Model をクリックして、モデルをBosch AMU(*.dcm、*.cdfx）にエクス
ポートします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。

5.7.12 Bosch Flatbuffersにエクスポートする
再帰型ニューラルネットワーク（RNN：Recurrent Neural Network）および畳み込み
ニューラルネットワーク（CNN：Convolutional Neural Network）に限り、Bosch 
Flatbuffersにエクスポートすることができます。

モデルをFlatbuffersにエクスポートすると、出力ごとに*.dcmファイルが生成されます。
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Bosch Flatbuffersにモデルをエクスポートする
 1. File > Export Model > Bosch Flatbuffers
 2. ファイル名を定義するためのベース名（Base Name）とターゲットフォルダ（Target 

Folder）を設定します。ファイル名は <base name>_<output> となります。
 3. エクスポートする入力（Inputs）と出力（Outputs）をテーブルから選択します。エ

クスポートされるモデルに対して入力が渡される順番は、  ／  ボタンで変更できま
す。 
テーブル内では、CTRL／SHIFT による標準的な選択機能が使用でき、また LMB を押し
下げたままカーソルをドラッグして複数のセルや行を選択することもできます。 エクスポート
されるモデル内における各入力の位置は、♯ 列に表示されます。
使用されている入力のみをエクスポートするには、Used Inputs Only を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。エクスポートフォ
ルダへのリンクがログウィンドウに表示されます。
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6 チュートリアル：ASCMO-DYNAMIC ExpeDesの操作
ASCMO-DYNAMIC ExpeDesは、空間充填による統計的実験計画を作成するためのツー
ルです。目標値のグリッド空間内への測定値の分散と測定チャンネルの勾配を計画するのに最
適で、これはASCMO-DYNAMICでのモデルトレーニングを行うための要件となります。
本章では、ASCMO-DYNAMIC ExpeDesを用いてダイナミックモデルのための実験計画を作
成する方法を、ステップを追って説明します。

6.2  ステップ1：一般設定（ページ62）
最初のステップとして、実験計画の測定ポイント数、および入力の数とコンフィギュレーショ
ンを定義します。
6.3  実験計画の可視化 （ページ65）
計画データは、グラフやテーブルで表示して、いつでも評価することができます。
6.4  ステップ2：範囲制限（"Constraints"） （ページ67）
このステップでは、ある変数の測定値の制限範囲を、他の1つまたは2つの変数の関数と
して定義します。
6.5  ステップ3：入力の圧縮（"Input Compression"） （ページ76）
このステップでは、測定空間の各領域ごとに測定ポイントを圧縮することができます。
6.6  ステップ4：定常状態ポイント（"Steady State Points"） （ページ78）
このステップでは、実験計画内で「留まる頻度」を持つ動作ポイントを定義することができ
ます。さらに、「定常状態フェーズ」とその期間を定義することができます。
6.7  ステップ5：ブロック構成（"Block Configuration"）（ページ84）
このステップでは、実験計画を、個別に測定できる複数のパーツ（「ブロック」）に分割で
きます。各ブロックは実験計画の要件に相当し、空間充填的なものになります。
6.8  ステップ6：スニペット設定（"Snippet Configuration"）（ページ86）
チュートリアルではこのステップは省略します。
6.9  ステップ7：演算入力（"Calculated Inputs"）（ページ86）
チュートリアルではこのステップは省略します。
6.10  ステップ8：エクスポート（"Export"）（ページ87）
このステップでは、プロジェクトおよび実験計画自体のプロパティが表示されます。データを
各種フォーマット（*.xlsx、*.xls、*.csv）でエクスポートすることができます。ま
た、データを各種形式（散布図、密度プロット、スコープビュー、テーブル）で表示できま
す。

6.1 ASCMO-DYNAMIC ExpeDesを起動する
ASCMO-DYNAMIC ExpeDesは、Windowsスタートメニュー、または ASCMO-DESK 
ウィンドウ（図5-2:  ページ26参照）から起動します。
ASCMO-DYNAMIC ExpeDesの起動

 1. WindowsスタートメニューのETAS ASCMO V5.16プログラムグループから、
ASCMO ExpeDes Dynamic V5.16 を選択します。
ASCMO-DYNAMIC ExpeDesスタートウィンドウが開きます。
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 2. ASCMO-DYNAMIC ExpeDesを空のプロジェクトで起動し（New >  Open 
Project）、デモプロジェクト（Demo Files）または既存のプロジェクト（Open >

 Open Project/Recent Projectsから選択）を開くことができます。

図6-1: ASCMO-DYNAMIC ExpeDesスタートウィンドウ

 3. ASCMO-DYNAMIC ExpeDesを空のプロジェクトで起動するには：
 i. 左側のメニューパネル内の New をクリックします。

 ii.  をクリックします。

ASCMO-DYNAMIC ExpeDesメインウィンドウの第1ページが開き、デフォルト設定が
表示されます。

図6-2: ASCMO-DYNAMIC ExpeDesメインウィンドウ

 4. ここで既存のASCMO-DYNAMIC ExpeDesプロジェクトを開くには、以下のように操作
します。
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 i. ASCMO-DYNAMIC ExpeDesメインウィンドウで、左側のメニューパネル内の 
Open をクリックします。

 ii.  をクリックします。
オープンファイルダイアログが開きます。

 iii. 開きたい *.exde ファイルを選択し、Open をクリックします。
選択したプロジェクトが開き、ASCMO-DYNAMIC ExpeDesメインウィンドウに表示さ
れます。

6.2 ステップ1：一般設定

ご注意ください！ 
誤った実験計画による損害
ASCMO-DYNAMIC ExpeDes における誤ったエンジン設定は、エンジンやテストベンチの損
傷を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエン
ジンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

ASCMO-DYNAMIC ExpeDesについては、6.10  ステップ8：エクスポート（"Export"）
（ページ87）と6.2  ステップ1：一般設定（上記）を参照してください。
最初のステップとして、実験計画の測定ポイント数、および入力の数とコンフィギュレーションを定
義します。
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6.2.1 入力の設定 
新しいASCMO-DYNAMIC ExpeDesプロジェクトを作成すると、数個の入力が自動的に作
成されます。これらは適切な名前を付けて設定する必要があり、入力の追加が必要になる場合
もあります。
新しい入力を定義する

 1. 新しい入力を追加するには Add をクリックします。
新しい入力がリストの末尾に追加されます。
行番号をクリックして特定の行を選択してから Add をクリックした場合は、その行の下に
新しい入力が追加されます。

 2. 既存の入力を複製するには、入力を選択し（CTRL／SHIFT を使用して複数選択も可
能）、Clone をクリックします。
オリジナルの入力の下に<input_name>_2という名前の複製が作成されます。

入力を設定する
上記のステップで作成された入力は、実験計画を作成する前に、以下のように設定しておく必
要があります。入力を設定するには、以下のように操作します。

 1. 設定したいセルをクリックします。
セルが入力フィールドまたはドロップダウンリストになります。

 2. 値を入力または選択して <ENTER> を押します。

ASCMO-DYNAMIC V5.16 | ユーザーガイド



6 チュートリアル：ASCMO-DYNAMIC ExpeDesの操作 | 64

以下のパラメータを設定できます。

Input Name 測定する入力量の名前

Minimum / 
Maximum

入力の測定範囲の上下限値

Type 入力のタイプRamp または Step を選択できます。

Max Up
Max Down

Ramp タイプ：正方向と負方向の最大傾斜
Step タイプ：正方向と負方向の最大ジャンプ幅

注記 

入力の名前は一意である必要があります。

 3. 矢印ボタン h／i を使用して、リスト内の各入力の順番を変更することができます。

入力の名前をインポートする
 1. Import ボタンで、以下のいずれかのフォーマットのファイルから名前のリストをインポート

することができます。
 l ラベルファイル（*.lab）－ ETAS INCA用の変数ラベルファイルなど
 l MS Excel（*.xls、*.xlsx）
 l カンマ区切りのテキストファイル（*.csv）
 l コンフィギュレーションファイル（*.ini）－ ETAS ASCMOチャンネル設定ファイル

など
ウィンドウが開くので、実際にインポートする名前を選択します。

入力を削除する
 1. 入力を削除するには、対象の行を選択してから Delete をクリックします。

注記 

<CTRL> を押しながら複数の入力を選択すると、それらを同時に削除することができ
ます。

6.2.2 測定量の設定 
Input Configuration フィールドの下で、推定される実験の所用時間（Desired 
Experiment Duration）と1行を処理する絶対時間（Min / Max Time for 
Change）を設定します。
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注記 

ステップ1（General Settings）の設定内容から実験計画が作成されます。作成された
実験計画は、*.xls または *.csv フォーマットでエクスポートできます。実験計画をエクス
ポートする方法については、6.10  ステップ8：エクスポート（"Export"）（ページ87）を参
照してください。

6.3 実験計画の可視化 
計画データは、グラフやテーブルで表示して、いつでも評価することができます。
チュートリアルを実行する際に、本項の6.3  実験計画の可視化 （上記）は必須ではありませ
ん。6.4  ステップ2：範囲制限（"Constraints"） （ページ67）に進むことができます。
実験計画を散布図で表示する

 1. 実験計画の2次元プロットを表示するには、ASCMO-DYNAMIC ExpeDesメインウィ
ンドウで View > Scatter Plot を選択します。

 2. Experiment Scatter Plot ウィンドウに表示する軸を指定するには、View > 
Select Axes を選択します。

実験計画を密度プロット（Density Plot）で表示する
密度プロットには実験計画の軌跡が表示され、実験計画のダイナミクスが可視化されます。軌
跡の明暗で各点に留まる頻度がわかります。つまり、より明るい点は、実験計画において留まる
頻度がより高い点であることを示します。この表示は時間には依存しません。
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 1. 測定計画のデータを密度プロットに表示するには、ASCMO-DYNAMIC ExpeDesメイ
ンウィンドウで View > Density Plot を選択します。

 2. Density Plot ウィンドウに表示する軸を指定するには、View > Select Axes を
選択します。
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実験計画を時間軸ビュー（Scope View）で表示する
 1. 実験計画のデータを時間軸に沿ってプロット表示するには、ASCMO-DYNAMIC 

ExpeDesメインウィンドウで View > Scope View を選択します。

注記 

時間軸に沿ったプロットをクリックすると、その位置（時間）の値が表示されます。マウスの左ボタンを押し下
げて、時間依存の値を時間軸に沿って連続的に取得することができます。

実験計画をテーブルで表示する
 1. 測定計画のデータをテーブル形式で表示するには、View > Table View を選択しま

す。

6.4 ステップ2：範囲制限（"Constraints"） 
このステップでは、ある変数の測定値の制限範囲を、他の1つまたは2つの変数の関数として定
義します。
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図6-3: ASCMO-DYNAMIC ExpeDes ステップ2：範囲制限（Curve タイプ）

これらの制限条件について、追加や削除、インポート、可視化、設定が行えます。
制限を追加、削除、管理する

 1. 新しい制限を作成するには、Add をクリックします（図6-3:  上記のAを参照）。
リストの末尾に新しい制限の行が追加されます。

 2. Constraint Name 列のセルをクリックして、制限の名前を入力します。
 3. Constraint Type 列のセルをクリックして、コンボボックスから制限のタイプを選択しま

す。
次のタイプから選択できます：Map、Curve、Time Expansion Value、Time 
Expansion Gradient

マップとカーブについては6.4.1  "Map"／"Curve" タイプの制限 （下記）を参照してく
ださい。
Time Expansion Value と Time Expansion Gradient については、オン
ラインヘルプ（<F1>）を参照してください。

 4. Active 列で、使用したい制限をアクティブにします。
 5. 上下の矢印ボタン h i を使用して、リスト内の各制限の順番を変更することができます。

 6. Delete をクリックすると、選択されている行が削除されます。
Curve タイプと Map タイプの制限の設定方法は、6.4.1  "Map"／"Curve" タイプの制限 
（下記）を参照してください。

6.4.1 "Map"／"Curve" タイプの制限 
変数を選択する

 1. Show 列で、編集したい制限をアクティブにします。
ウィンドウ下部にその制限の内容が表示されます。x-Axis／y-Axis コンボボックス
（マップの場合はさらに z-Axis ドロップダウンリスト）も表示されます。
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 2. 各ドロップダウンリストで、軸に割り当てる入力を選択します。
カーブの場合の依存関数は y(x) で、マップの場合は z(x,y) です。

暫定値と制限のグラフ表示
リスト内で選択された制限の内容が完全に定義されていると、現在の実験計画の測定ポイント
が2D（カーブ－ 図6-3:  前ページを参照）または3D（マップ）でプロット表示されます。
この「暫定値」の表示は、Preliminary Values チェックボックス（図6-3:  前ページ内の
D）で操作できます。処理をスムーズにするため、一部のみが表示されます。プロット内に表示さ
れる大きなサイズの点を動かして、領域の制限を変更することもできます。
測定範囲の制限を変更する

 1. Show 列で、編集したい制限をアクティブにします。
ウィンドウ下部にその制限の内容が表示されます。

 2. 制限プロット（図6-3:  前ページのC）内で、制限ライン／領域の点にマウスポインタを
合わせ、マウスボタンを押し下げます。
マウスポインタが上下矢印に変わります。

 3. マウスボタンを押し下げたまま、その点を所望の位置にドラッグします。
以下の図は、中速域でトルク制限を設定する操作を示しています。

プロット表示にはツールバーの各ボタン（Zoom In、Zoom Out、Pan、Rotate 3D）を
利用することもできます。

右側のテーブル（図6-3:  前ページのE）の Upper および Lower タブには、制限されるポイ
ントを表す値が表示され、この値を直接変更することもできます。 グリッドノードの表示／編集用
テーブル（次ページ）を参照してください。
制限の表示と編集には以下のようなオプションも使用できます。
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Display Options
 l Preliminary Values：定義されたすべての制限によって計算される暫定値の表

示／非表示
 l Upper/Lower：制限によって定義される上下限の表示／非表示
Time Dependence：変数の値の範囲と勾配の範囲を、時間の関数により制限す
ることができます。詳細は、オンラインヘルプを参照してください。

グリッドノードの表示／編集用テーブル
ウィンドウ右端にあるテーブル（図6-3:  ページ68のE）でもグリッドノードを編集することができま
す。上限と下限の制限にそれぞれ専用のタブが用意されています。
グリッドノード数を変更する

 1. Redefine Grid をクリックします。
Constraint:Redefine Grid ウィンドウが開きます。

 2. 制限軸のポイント数を変更するには、以下のように操作します。
 i. 制限軸のドロップダウンリストで、Count を選択します。

ポイント数は、それぞれの制限軸の入力フィールドに表示されます。
 ii. 新しい値を入力します。

 3. 制限軸のグリッドベクトルを直接指定するには、以下のように操作します。
 i. 制限軸のドロップダウンリストで、Vector を選択します。

ベクトルは、それぞれの制限軸の入力フィールドに表示されます。
 ii. ベクトルの値を編集します。

注記 

Count タイプの場合、各グリッドポイントは等間隔になります。Vector タイプの場
合は、各グリッドポイントを不均等に分散することができます。

 4. OK をクリックします。
設定に応じてポイントが変更されます。Constraints: Redefine Grid ウィンドウが
閉じます。
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6.4.2 マップ／カーブの管理
本項では、制限に使用されるマップ／カーブの管理方法（作成、編集、削除、インポート、エク
スポート）の方法について説明します。
マップ／カーブのデータをインポートする
制限に使用するマップやカーブのデータが所定のフォーマットのファイル（*.dcm、*.cdfx、
*.csv、*.xls、*.xlsx、*.xlsm、*.ascmo）に保存されている場合は、それをインポー
トして使用することができます。

 1. マップ／カーブをインポートしたい制限について、Show 列をオンにします。
 2. Parameter/Model > Import をクリックします。

ファイル選択ウィンドウが開きます。
 3. インポートしたいファイルを選択して、開く をクリックします。

Import Maps or Models ウィンドウが開きます。ファイルに保存されているマップ／
カーブの一覧が表示されます。

 4. ドロップダウンリストで、カーブの場合はX軸、マップの場合はX軸とY軸に割り当てる入力
を選択します。
カーブの場合は、Y軸に入力を割り当てても無視されます。

 5. Import 列のチェックボックスで、インポートしたいアイテムを指定します。
 6. Name 列に、インポートするアイテムの一意の名前を入力します。
 7. OK をクリックします。

選択されたアイテムが、現在選択されている制限にインポートされます。
インポート後、Scale/Shift をクリックしてスケールとオフセットを加えることにより、上下
限値を変更して範囲を調整することができます。

注記 

下側の境界を広げるには、負のオフセット値を入力します。
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インポートしたマップ／カーブを制限に割り当てる方法は、 既存のマップ／カーブを制限に割り当
てる（次ページ）を参照してください。
マップ／カーブのデータをエクスポートする
現在表示されている制限のマップ／カーブや、ASCMO-DYNAMIC ExpeDesプロジェクト内で
定義されているマップ／カーブをエクスポートすることができます。使用できるエクスポートフォーマッ
トは、*.dcm、*.cdfx、*.csv などです。

 1. 現在表示されている制限のマップ／カーブをエクスポートする
 i. テーブル領域（図6-3:  ページ68のE）で、Export をクリックします。

Save Constraint Maps ウィンドウが開きます。
 ii. ファイルタイプを選択します。
 iii. ファイルの場所と名前を指定して、保存 をクリックします。

Specify label names ウィンドウが開きます。
 iv. このウィンドウで、マップ／カーブの名前（ラベル）を入力します。
 v. OK をクリックします。

上限と下限に使用されるマップ／カーブがエクスポートされます。
 2. ASCMO-DYNAMIC ExpeDesプロジェクト内のマップ／カーブをエクスポートする

 i. Parameter/Model > Export を選択します。
"Export Curve and Maps" ウィンドウが開きます。

 ii. Export 列で、エクスポートするマップ／カーブを選択します。
すべてのマップ／カーブを選択するには Select All、選択解除するには Unselect 
All をクリックします。

 iii. OK をクリックします。
Save Constraint Maps ウィンドウが開きます。

 iv. ファイルタイプを選択します。
 v. ファイルの場所と名前を指定して、保存 をクリックします。

マップ／カーブがエクスポートされます。Export Curve and Maps ウィンドウが閉
じます。
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既存のマップ／カーブを制限に割り当てる
マップ／カーブがASCMO-DYNAMIC ExpeDesプロジェクト内に存在している場合は、
Import ボタンで選択し、制限に割り当てることができます。

 1. マップ／カーブのデータを割り当てたい制限を表示します。
 2. 右下の Import ボタンをクリックします（図6-3:  ページ68のE）。

Select Map from imported Map(s) または Select Curve from 
imported Curve(s) ウィンドウが開きます。

注記 

ASCMO-DYNAMIC ExpeDesプロジェクト内に使用できるマップ／カーブが存在し
ない場合は、ファイル選択ダイアログボックスが開くので、マップデータ（*.dcm、
*.cdfx、*.csv、*.xls、*.xlsx、*.xlsm、*.ascmo）をインポートして使
用します。
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 3. 上限と下限にそれぞれ異なるマップ／カーブを使用するには、Use one map 
(/curve) for upper and lower constraint チェックボックスをオフにします。

 4. List of Maps/List of Curves 列で、上限と下限に使用するマップ／カーブを選択
します。

 5. OK をクリックします。
Select Map from imported Map(s) または Select Curve from 
imported Curve(s) ウィンドウが閉じます。上限と下限が制限に割り当てられ、表
示されます。
インポート後、Scale/Shift をクリックしてスケールとオフセットを加えることにより、上下
限値を変更して範囲を調整することができます。

注記 

下側の境界を広げるには、負のオフセット値を入力します。

マップ／カーブを作成する
 1. ASCMO-DYNAMIC ExpeDesウィンドウで、Parameter/Model > New を選

択します。
Create new Map/Curve ウィンドウが開きます。

 2. 名前を入力します。
 3. マップ／カーブの入力を選択します。
 4. 上限値（Max）と下限値（Min）を入力します。
 5. OK をクリックします。

Editing Map/Curve ウィンドウと Map <name> ／ Curve <name> ウィン
ドウが開きます。ここでマップを編集することができます。
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マップ／カーブを編集する
 1. ASCMO-DYNAMIC ExpeDesメインウィンドウで、Parameter/Model > Edit 

> <map/curve name> を選択します。
Editing Map/Curve ウィンドウと Map <name> ／ Curve <name> ウィン
ドウが開きます。

 

 2. グリッドポイントを再定義するには、以下のように操作します。
 i. Editing Map/Curve ウィンドウで、Redefine Grid をクリックします。
 ii.  グリッドノード数を変更する（ページ70）を参照してグリッドを編集します。

 3. マップ／カーブのスケールとオフセットを指定するには、以下のように操作します。
 i. Editing Map/Curve ウィンドウで、Scale/Shift をクリックします。

Scale and Shift Map ウィンドウが開きます。

 ii. このウィンドウで、マップ／カーブのスケールファクタとオフセットを入力します。

注記 

下側の境界を広げるには、負のオフセット値を入力します。

 iii. OK をクリックします。
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マップ／カーブの名前を変更する
 1. ASCMO-DYNAMIC ExpeDesメインウィンドウで、Parameter/Model > Edit 

> <map/curve name> を選択します。
Editing Map/Curve ウィンドウと Map <name> ／ Curve <name> ウィン
ドウが開きます。

 2. Name フィールドにマップ／カーブの名前を入力します。
 3. Map <name>／Curve <name> ウィンドウで OK をクリックして変更内容を確

定し、2つのウィンドウを閉じます。
Apply をクリックすると、変更内容は確定されますが、ウィンドウは閉じません。

マップ／カーブを削除する
 1. ASCMO-DYNAMIC ExpeDesメインウィンドウで、Parameter/Model > 

Delete を選択します。
Delete Curve and Maps ウィンドウが開きます。

 2. Delete 列で、削除したいマップ／カーブを選択します。
 3. Delete をクリックします。

Confirm ウィンドウが開きます。削除を確定、またはキャンセルします。
 4. 選択したマップ／カーブの削除を実行するには、Yes をクリックします。

6.5 ステップ3：入力の圧縮（"Input Compression"） 
このステップでは、測定空間の各領域ごとに測定ポイントを圧縮することができます。
各測定ポイント同士をより近くすることにより、モデル精度を向上できます。
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図6-4: ASCMO-DYNAMIC ExpeDes ステップ3：入力の圧縮（"Positioned 
Compression" タイプ）

圧縮する入力を選択する
 1. Compression 列で、圧縮したい入力のチェックボックスを選択します（図6-4:  上記

のA）。
ウィンドウ下部に、選択された入力の内容が表示されます。

6.5.1 Compression Configuration 領域
Compression Configuration" 領域（図6-4:  上記のB）で、圧縮のタイプと方向を指
定します。圧縮のタイプは2種類から選択できます。

Positioned Compression：このタイプでは、自由に選択可能な1点に向けて圧
縮が行われます。
 l Gain：Position で指定されている中心に向かう圧縮の度合い
 l Position：圧縮の中心位置
Edge Compression：測定範囲の一方または両方の端に向けて圧縮が行われま
す。
 l Gain：圧縮の度合い
 l Position：圧縮は、左端（Left Edge）、右端（Right Edge）、両端

（Both Edges）のいずれかの方向に行われます。

6.5.2 View 領域
View 領域（図6-4:  上記のCとD）には測定ポイントの位置がグラフィカルに表示され、設定
された圧縮のようすがわかります。その下には、圧縮の結果得られた各区間の測定値数（rel. 
Size in %）が一覧表示されます。

6.5.3 圧縮の適用例 
下図では、Airmass の測定範囲（制限なし）に Edge Compression が適用され、両
端に向けてゲイン75で圧縮されています。
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適用された圧縮を散布図で可視化（View > Scatter Plot）すると、実験計画内で空間
充填された値が端の方向に圧縮されたことがわかります。

6.6 ステップ4：定常状態ポイント（"Steady State Points"） 
このステップでは、実験計画内で「留まる頻度」を持つ動作ポイントを定義することができます。さ
らに、「定常状態フェーズ」とその期間を定義することができます。
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図6-5: ASCMO-DYNAMIC ExpeDes ステップ4：定常状態ポイント

6.6.1 軸の選択
Select Axes 領域（図6-5:  上記の A）で、定常状態ポイント用の軸を設定することができ
ます。これによって、実験計画において明確に考慮しなければならない動作ポイントを定義するこ
とができます。動作ポイント軸の値は User Defined Positions 領域で指定でき、残りの入
力は実験計画に合わせて変化します。

6.6.2 ユーザー定義ポイント
"User Defined Positions" 領域（図6-5:  上記のB）では、定常状態ポイントがテーブルと
プロットに表示されます。ここでは、定常状態ポイントの各種操作（追加、インポート／エクス
ポート、編集、削除）が行えます。
定常状態ポイントを手動で追加する

注記 

User Defined Positions 領域は、Select Axes 領域で軸の入力を選択しないと、
有効になりません。

 1. New 行のセルをクリックします。
セルが入力モードになります。

 2. 列の値を入力します。
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有効な定常状態ポイントについては、すべての列が編集されている必要があります。

列 意味

入力名（x-Axisおよびy-Axis
として定義されたもの）

定常状態ポイント（Speed、Torqueなど）
の値

Weight DoE内で定常状態ポイントにヒットする相対
頻度。
値が大きいほどヒットする頻度が上がります。

注記 

すべての重みの合計が75以下になるようにしてください。

 

Stopping Probability 各ポイントにヒットした際に定常状態フェーズが
発生する確率（0～100）
0：定常状態フェーズが絶対に発生しない
100：定常状態フェーズが必ず発生する

t min, t max t min～t maxの範囲から停留時間が抽出
されます。

定義された定常状態ポイントは、User Defined Positions 領域の右側部分にプ
ロット表示されます。

定常状態ポイントのグリッドを作成する

注記 

定常状態グリッドを追加すると、既存の定常状態ポイントは削除されます。
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 1. User Defined Positions 領域で New Grid をクリックします。
Create Grid ウィンドウが開きます。

 2. 各軸のポイント数を変更するには、以下のように操作します。
 i. 軸のドロップダウンリストで、Count を選択します。

ポイント数は、それぞれの軸の入力フィールドに表示されます。
 ii. 新しい値を入力します。

 3. 各軸のグリッドベクトルを直接入力するには、以下のように操作します。
 i. 制限軸のドロップダウンリストで、Vector を選択します。

ベクトルは、それぞれの軸の入力フィールドに表示されます。

 ii. ベクトルの値を編集します。

注記 

Count タイプの場合、各グリッドポイントは等間隔になります。Vector タイプの場
合は、各グリッドポイントを不均等に分散することができます。

 4. グリッドポイントの数を減らすには、Staggering の下のオプションをオンにします。
 5. OK をクリックします。

テーブルとプロットに定常状態ポイントが表示されます。Create Grid ウィンドウが閉じま
す。
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定常状態ポイントをアクティブ化／非アクティブ化する
 1. すべての定常状態ポイントをアクティブにするには、Active オプションをオンにします。

各定常状態ポイントを個別に非アクティブにしない限り、実験計画においてすべての定常
ポイントが考慮されます。

 2. 個々の定常状態ポイントを非アクティブにするには、重みを 0 に設定します。
 3. すべての定常状態ポイントを非アクティブにするには、Active オプションをオフにします。

この状態においても、定常状態ポイントの追加や編集、インポート／エクスポート、削除
は行えますが、実験計画においてどの定常状態ポイントも考慮されなくなります。

個々の定常状態ポイントを編集する
 1. 編集したいポイント行のセルをクリックします。

セルが入力モードになります。
 2. 列の値を入力します。

すべての定常状態ポイントを一括編集する
 1. User Defined Positions 領域で Edit をクリックします。

Edit Table ウィンドウが開きます。

 2. Weightドロップダウンリストで、重みを変更する方法を選択します。
Equally distribute weights with total quantity of ...：重
みの合計を、n 個の定常状態ポイントにすべて同じ割合（sum/n）で分散します。
Renorm current weights to total quantity of ...：すべての定
常状態ポイントの重みの合計が指定された値になるように、全ポイントの重みをスケーリン
グします。この際、重みの割合は保持されます。

 3. 入力フィールドに全ポイントの重みの合計を入力します。
 4. Stopping Probability、t min、t max 行を以下のように設定します。

 i. オプションを確定するには、チェックボックスをオンにします。
 ii. 入力フィールドに、すべての定常状態ポイントに適用したい値を入力します。

 5. OK をクリックします。
設定に応じて定常状態ポイントが変更されます。
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定常状態ポイントを削除する
 1. 定常状態ポイントテーブルで、削除したいポイントの行（複数可）を選択します。
 2. Delete をクリックします。

定常状態ポイントが確認メッセージなしに削除されます。
定常状態ポイントをインポートする
定常状態ポイントのグリッドは、*.csv ファイルや *.xls、*.xlsx、*.xlsm ファイルからイン
ポートすることができます。

 1. User Defined Positions 領域で Import List をクリックします。
ファイル選択ウィンドウが開きます。

 2. インポートしたいファイルを選択して、開く をクリックします。
ファイルに複数のワークシートが含まれる場合は、Select Sheet ウィンドウが開きます。

 3. ワークシートを選択して OK をクリックします。
Import Grid ウィンドウが開きます。ファイルに含まれる列の名前が各ドロップダウンリス
トに表示されます。

 4. Import Grid ウィンドウで、定常状態ポイントテーブルの各列に、ファイル内の適切な
列を割り当てます。

 5. Dataドロップダウンリストで、インポートモード（Add / Replace）を選択します。
 6. OK をクリックしてインポートを実行します。

定常状態ポイントをエクスポートする
定常状態ポイントのリストをエクスポートすることができます。リストの一部のみをエクスポートする
ことはできません。使用できるエクスポートフォーマットは、*.csv、*.xls、*.xlsx のいずれか
です。
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 1. User Defined Positions 領域で Export List をクリックします。
ファイル選択ウィンドウが開きます。

 2. ファイルタイプを選択します。
 3. ファイルの場所と名前を指定して、保存 をクリックします。

6.6.3 ランダムポジション
Random Positions 領域（図6-5:  ページ79）では、ランダムな定常状態フェーズを有効
にして、所定の確率で定常状態が発生するようにすることができます。
ランダムな定常状態フェーズを有効にする

 1. Random Positions 領域で、Activate random steady state phases を
オンにします。

 2. Stopping Probability 列に、定常状態フェーズが発生する確率（0～100）を入
力します。
0：定常状態フェーズが絶対に発生しない
100：定常状態フェーズが必ず発生する

 3. t min／t max フィールドに、停留時間の最大値と最小値を入力します。この範囲の
時間が停留時間となります。

6.7 ステップ5：ブロック構成（"Block Configuration"）
このステップでは、実験計画を、個別に測定できる複数のパーツ（「ブロック」）に分割できます。
各ブロックは実験計画の要件に相当し、空間充填的なものになります。
ブロック構成を利用することのメリットは測定工数を削減できる点にあります。小数のブロックを測
定するだけで良好なモデル精度を実現でき、すべてのブロックを測定しなくても測定を終了するこ
とができます。

図6-6: ASCMO-DYNAMIC ExpeDes ステップ5：ブロック構成

"Block Size Table" 領域（ブロックサイズテーブル）
各ブロックのサイズを定義します。
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定義済みの測定ブロックの合計サイズ（Sum of Assigned Measurements）が表示
されます。この値が現在の測定値の数（Current Number of Measurements）と異
なる場合は、その差（Deviation）が赤で表示されます。

"Block Size View" 領域（ブロックサイズビュー）
ブロックのサイズ（Block Size Table 領域に定義されている内容）がグラフィカル表示されま
す。
ブロックの作成と編集を行う

 1. Number of Blocks フィールドにブロック数を入力して、<ENTER> を押します。
n 個の同サイズのブロックが作成されます。

または
テーブルの最下行（Block ID = Add）の Number of Measurement 列に、
新しいブロックに割り当てる測定値の数を入力して、<ENTER> を押します。

新しいブロックが追加されます。
 2. 各ブロックの Duration [ts] を調整して、割り当てられた測定値の総数

（Duration of Assigned Blocks [ts]）が測定値の数（Total 
Measurement time [ts]）と一致するようにしてください。

注記 

割り当てられた測定値の総数が現在の測定値の数と一致していない場合、実験計
画は無効になります。

ブロックを削除する
 1. ブロックサイズテーブルで、削除したいブロックを選択します。
 2. Delete をクリックします。

ブロックが削除されます。削除されたブロックに含まれていた測定値の数が、テーブルの下
の Deviation フィールドの値に追加されます。
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 3. 各ブロックの測定値の数を調整して、すべての測定値がブロックに割り当てられるようにし
てください。

6.8 ステップ6：スニペット設定（"Snippet Configuration"）
このステップでは、外部の走行サイクルを実験計画に組み込むことができます。

図6-7: ASCMO-DYNAMIC ExpeDes ステップ6：スニペット設定

チュートリアルではこのステップは省略します。詳細は、オンラインヘルプを参照してください
（F1）。

6.9 ステップ7：演算入力（"Calculated Inputs"）
このステップでは、所定の式によって演算される入力を定義して追加することができます。
演算入力はすべてのビュー（散布図、スコープビュー、テーブルビューなど）に表示されます。それ
らは、実験計画とともにエクスポートされます。
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図6-8: ASCMO-DYNAMIC ExpeDes ステップ7：演算入力

チュートリアルではこのステップは省略します。詳細は、オンラインヘルプを参照してください
（F1）。

6.10 ステップ8：エクスポート（"Export"）

ご注意ください！ 
誤った実験計画による損害
ASCMO-DYNAMIC ExpeDes における誤ったエンジン設定は、エンジンやテストベンチの損
傷を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエン
ジンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

ASCMO-DYNAMIC ExpeDesについては、6.10  ステップ8：エクスポート（"Export"）
（上記）と6.2  ステップ1：一般設定（ページ62）を参照してください。
このステップでは、プロジェクトおよび実験計画自体のプロパティが表示されます。データを各種
フォーマット（*.xlsx、*.xls、*.csv）でエクスポートすることができます。また、データを各
種形式（散布図、密度プロット、スコープビュー、テーブル）で表示できます。
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図6-9: ASCMO-DYNAMIC ExpeDes ステップ8：エクスポート

"Plan Generation" 領域（計画生成モード）
Plan Generation 領域で、実験計画のエクスポートテーブルに含める値を定義することがで
きます。

実験計画の生成 - タイプ1

エンジンダイナモメータの目標値が定義されています。試験装置において当該行のすべてのパラ
メータの処理が終了した時点の絶対時間（Time 列）がエクスポートテーブルに表示されま
す。
Ramp タイプとして定義されている入力については、目標値に到達するまでの指定時間が 
Ramp Time 列に表示されます。Ramp Time は定義済みの勾配に依存します。Step タ
イプとして定義されている入力については、所定の値を保持する時間が Hold Time 列に表示
されます。
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図6-10: エクスポートテーブル（タイプ1：目標値 + 待ち状態）のプレビュー

実験計画の生成 - タイプ2

タイプ1と似ていますが、テーブルに中間ポイントが追加されます。

図6-11: エクスポートテーブル（タイプ2：目標値 + 待ち状態 + 中間ポイント）のプレ
ビュー

実験計画の生成 - タイプ3

ASCMO-DYNAMIC V5.16 | ユーザーガイド



6 チュートリアル：ASCMO-DYNAMIC ExpeDesの操作 | 90

すべての出力値は Sample Time [s] で指定したサンプルタイムに依存します。サンプルタイ
ム は、すべての入力について新しい想定ポイントが検出されるまでの遅延時間を定義します。こ
こでは、エンジンダイナモメータにおいて各入力パラメータが目標値に到達したかどうかは問題にな
りません。

図6-12: エクスポートテーブル（タイプ3：目標値）のプレビュー

実験計画の生成 - タイプ4

この計画生成は、"Activate Wait States"チェックボックスに似ています。Sample Time に
応じてパスが再計算されます。

実験計画の生成 - タイプ5
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1つの入力値が目標値に達した時点で、他の入力の現在値が決定されます。

図6-13: エクスポートテーブルフォーマット "Full Trace" のプレビュー

注記 

Sample Time は、エクスポートテーブルフォーマットのタイプ3または4を指定した場合にのみ
定義できます。サンプルタイムには、"Project Properties" フィールドに表示されている 
Maximum Time for Change の値より大きい値は設定できません。
これを超える値を入力すると、Conflict ウィンドウが開きます。ドロップダウンリストで、
Maximum time for change (<m>) と Sample time (<n>) のどちらの値を保
持するかを決めることができます。その値が Maximum Time for Change と Sample 
Time の両方に割り当てられます。

値の精度
Rounding of Values 領域で、測定値をセットする際の精度を指定できます（例：エンジ
ンテストベンチでのエンジン回転数）。
値の丸め条件を変更する

 1. Rounding of Values 領域で、編集したい入力の Precision 列をクリックします。
セルが入力モードになります。

 2. 精度の値を入力します。

実験計画のエクスポート
計画生成モードと入力精度を設定した後は、実験計画をエクスポートすることができます。
計画をエクスポートする
実験計画をエクスポートするには、以下のように操作します。

 1. 前回選択されたファイルのパス、名前、フォーマットでエクスポートするには、Export をク
リックします。

または
Export As をクリックします。
ファイル選択ウィンドウが開きます。

 2. エクスポートファイルのタイプを選択します。
使用できるフォーマットは、*.xlsx、*.xls、*.csv のいずれかです。
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 3. エクスポートファイルのパスとファイル名を入力、または選択します。
既存のファイルを指定すると、警告なしに上書きされます。

 4. 保存 をクリックします。
設定に従って実験計画がエクスポートされます。

"Project Properties"／"Export Log" 領域（プロジェクトプロパティ／エク
スポートログ）
Project Properties 領域 には、プロジェクトと実験計画のプロパティが表示されます。
Export Log 領域 には、最近実行したエクスポートの履歴情報が表示されます。
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7 お問い合わせ先

テクニカルサポート

各国支社の営業やテクニカルサポートについての情報は、以下の
ETASのウェブサイトをご覧ください。
www.etas.com/hotlines
ASCMOに関する個別のお問い合わせは、以下の専任サポートチーム
までご連絡ください。
ascmo.support.de@etas.com

ETASは各製品のトレーニングを提供しています：
www.etas.com/academy

 

ETAS本社

ETAS GmbH

Borsigstraße 24 Phone： +49 711 3423-0

70469 Stuttgart Fax： +49 711 3423-2106

Germany Internet： www.etas.com
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用語集

A
ACF

AutoCorrelation Function（自動相関関数）

ASC GP
ASCMO Gaussian Process

ASC GP-SCS
ASCMO Gaussian Process Sparse Constant Sigma

ASC GP-Spectrum
ASCMO Gaussian Process Spectrum

C
CCF

Cross-Correlation Function（相互相関関数）

CNN
Convolutional Neural Networks（畳み込みニューラルネットワーク）

D
DoE

Design of Experiment（実験計画）

G
GPU

Graphics Processing Unit（グラフィック処理ユニット）

GRU
Gated Recurrent Update（ゲート付き再帰型更新）

I
IACF

Inverse AutoCorrelation Function（逆自己相関関数）

ISP
InterSection Plot（インターセクションプロット）

L
LSTM

Long Short-Term Memory（長短期記憶）
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M
MOCA

与えられたデータを用いてファンクションのモデリング（MOdeling）と適合（CAlibration）を行うため
のツール

N
NaN

Not a Number（非数）

NARX
Nonlinear AutoRegression with eXogenous inputs（外生入力を伴う非線形自己回帰）

O
ODCM

Online DoE with Constraint Modeling（制限付きモデリングによるオンラインDoE）

OP
Operating Point（動作ポイント）

R
RDE

Real Driving Emissions（実路走行排気）

RNN
Recurrent Neural Network（再帰型ニューラルネットワーク）

T
TCN

Temporal Convolutional Network（時間畳み込みネットワーク）

は
ハウスドルフ距離

1つのデータセットの全データポイントから他の全データセットのデータポイントまでの最大ユークリッド距
離。
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